summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael J Evans (MJEvans) <mjevans1983@gmail.com>2009-07-14 18:02:37 +0000
committerMichael J Evans (MJEvans) <mjevans1983@gmail.com>2009-07-14 18:02:37 +0000
commit38f0b28825fed6eb6bebc27e8a50c59a93661230 (patch)
tree0d9007c4d2858bed210b69806cf07cb6c6409d99
parentapp-text/pdfedit: Eapi2fy it. Apply patch to fix boost compilation problems (... (diff)
downloadsunrise-38f0b28825fed6eb6bebc27e8a50c59a93661230.tar.gz
sunrise-38f0b28825fed6eb6bebc27e8a50c59a93661230.tar.bz2
sunrise-38f0b28825fed6eb6bebc27e8a50c59a93661230.zip
sys-apps/aeuio: First ebuild for bug 277329 about aeuio, a portable, extendable, initrd/initramfs builder supporting mdadm, lvm, and end user extensions for the root filesystem. Thank you Thomas Sachau, Markos Chandras and Romain Perier.
svn path=/sunrise/; revision=8826
-rw-r--r--sys-apps/aeuio/ChangeLog11
-rw-r--r--sys-apps/aeuio/Manifest4
-rw-r--r--sys-apps/aeuio/aeuio-0.0.3.ebuild48
-rw-r--r--sys-apps/aeuio/metadata.xml9
4 files changed, 72 insertions, 0 deletions
diff --git a/sys-apps/aeuio/ChangeLog b/sys-apps/aeuio/ChangeLog
new file mode 100644
index 000000000..59027cf43
--- /dev/null
+++ b/sys-apps/aeuio/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-apps/aeuio
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 14 Jul 2009; Michael J Evans (MJEvans) <mjevans1983@gmail.com>
+ +aeuio-0.0.3.ebuild, +metadata.xml:
+ First ebuild for bug 277329 about aeuio, a portable, extendable,
+ initrd/initramfs builder supporting mdadm, lvm, and end user extensions for
+ the root filesystem. Thank you Thomas Sachau, Markos Chandras and Romain
+ Perier.
+
diff --git a/sys-apps/aeuio/Manifest b/sys-apps/aeuio/Manifest
new file mode 100644
index 000000000..724fbff12
--- /dev/null
+++ b/sys-apps/aeuio/Manifest
@@ -0,0 +1,4 @@
+DIST aeuio-0.0.3.tar.lzma 23813 RMD160 4e2990b1cc9a27b37b85b8b082775e0c72605142 SHA1 39c7a1a0ce570f9597fa911fe26108bae6a28b9c SHA256 5c31d80119d435eeb54519b0a7215ac20fb5894810b4073b1baf59357cfb20cc
+EBUILD aeuio-0.0.3.ebuild 1784 RMD160 2623149ae2dd7a48c9f50510306ea0af6fcd3305 SHA1 e879917eaa2b4f75660b96ef7a81400e20f43790 SHA256 2749699e32765352cd7584c68cc6a38ae90b169a08809bc1eb804302c400a264
+MISC ChangeLog 449 RMD160 df5abebd62ee59017f33eef62fc51a87017cad4f SHA1 27f16ca3dfcb5dae42accb5fd14d410ed25b1d07 SHA256 dee5106fa71fd7c3381a24117be2225df6045c67075f4bfed98fe64db0416806
+MISC metadata.xml 363 RMD160 fb832d968ab9f6929c1f588b19403544523f72a3 SHA1 40667b1c5381e0948d1cb5713b3ecefa20128098 SHA256 352ad75c4d4c6fc7d2efa095819a006691bae5974b7c56b9408d7bb734f7e2cb
diff --git a/sys-apps/aeuio/aeuio-0.0.3.ebuild b/sys-apps/aeuio/aeuio-0.0.3.ebuild
new file mode 100644
index 000000000..473049571
--- /dev/null
+++ b/sys-apps/aeuio/aeuio-0.0.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A simple, customizable, /etc inspired initrd or initramfs creator that supports root on mdadm / lvm"
+HOMEPAGE="https://sourceforge.net/projects/aeuio/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.lzma"
+
+LICENSE=" || ( GPL-2 GPL-3 LGPL-3 BSD CCPL-Attribution-3.0 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="sys-apps/busybox"
+# also depends on make, but make should be there on a gentoo system.
+
+pkg_setup() {
+ # While I believe this should go under /etc, especially intrepreting http://devmanual.gentoo.org/general-concepts/filesystem/index.html , I use the above location by request that I -not- use /etc
+ # local myDir="/etc/early-userspace/aeuio"
+ myDir="/usr/src/aeuio"
+}
+
+src_unpack() {
+ unpack ${A}
+ # Create update-initramfs-clean - This will be in the next (>0.0.3) upstream release
+ echo -e '#!/bin/bash'"\nOUTDIR=\"\$PWD\"\ncd \"${myDir}\"\nmake distclean nuke\nmake initramfs_gz initramfs_lzma && cp initramfs* \"\$OUTDIR\"" > ${S}/tools/update-initramfs-clean
+}
+
+src_compile() {
+ # Stop the default 'make' action.
+ true
+}
+
+src_install() {
+ # The Easy way, at least until things are more complicated.
+ dodir "${myDir}" || die "Install basedir failed!"
+ cp --no-dereference --preserve=links -R [^IL]* "${D}${myDir}/" || die "Install failed!"
+
+ insinto "${myDir}"
+ newins "INSTALL" "USAGE" || die
+ dosbin "tools/update-initramfs-clean" || die
+
+ elog "Please follow the instructions in ${myDir}/USAGE"
+ elog "You may also want to read ${myDir}/tools/process.txt"
+ elog "If your system only uses bare partitions, mdadm and/or lvm,"
+ elog " you may alternatly use update-initramfs-clean to generate"
+ elog " initramfs images in ${myDir}"
+}
diff --git a/sys-apps/aeuio/metadata.xml b/sys-apps/aeuio/metadata.xml
new file mode 100644
index 000000000..73615fab3
--- /dev/null
+++ b/sys-apps/aeuio/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>mjevans1983@gmail.com</email>
+</maintainer>
+ <longdescription>A simple, customizable, /etc inspired initrd or initramfs creator that supports root on mdadm / lvm.</longdescription>
+</pkgmetadata>