summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2008-10-22 17:27:10 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2008-10-22 17:27:10 +0000
commitfe682b8fc6843d042f42593f8ff81617233f3a24 (patch)
tree9a161a6e206ec3ff5a97e720cf4078b53c43a326 /dev-libs
parentnet-im/qutecom: new release candidate, drop amd64 keyword due to google break... (diff)
downloadsunrise-fe682b8fc6843d042f42593f8ff81617233f3a24.tar.gz
sunrise-fe682b8fc6843d042f42593f8ff81617233f3a24.tar.bz2
sunrise-fe682b8fc6843d042f42593f8ff81617233f3a24.zip
dev-libs/xml-security-c: New ebuild wrt bug 202952. Thanks to original bug authors and chithead, scarabeus, pva and tommy for help polishing.
svn path=/sunrise/; revision=7247
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xml-security-c/ChangeLog9
-rw-r--r--dev-libs/xml-security-c/Manifest4
-rw-r--r--dev-libs/xml-security-c/metadata.xml9
-rw-r--r--dev-libs/xml-security-c/xml-security-c-1.4.0.ebuild27
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/xml-security-c/ChangeLog b/dev-libs/xml-security-c/ChangeLog
new file mode 100644
index 000000000..05284785c
--- /dev/null
+++ b/dev-libs/xml-security-c/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-lib/xml-security-c
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 22 Oct 2008; Thomas Beierlein (TomJBE) <tb@forth-ev.de>
+ +xml-security-c-1.4.0.ebuild, +metadata.xml:
+ New ebuild wrt bug 202952. Thanks to original bug authors and chithead,
+ scarabeus, pva and tommy for help polishing.
+
diff --git a/dev-libs/xml-security-c/Manifest b/dev-libs/xml-security-c/Manifest
new file mode 100644
index 000000000..e084b66b2
--- /dev/null
+++ b/dev-libs/xml-security-c/Manifest
@@ -0,0 +1,4 @@
+DIST xml-security-c-1.4.0.tar.gz 934876 RMD160 6a9279c6b24583096523ab4d8b61941690c95954 SHA1 0e4b189aeb890693c9f97e3331cf66332c62be27 SHA256 955c570a965ab58d021a797ad85ad052ec37d9b8739d9a926d1081fb96c6245f
+EBUILD xml-security-c-1.4.0.ebuild 605 RMD160 1c5c13ec1f4cb3df6aa8647130ef37b070474254 SHA1 48c112e8a2131be37014a0ca7752d616a5c854a9 SHA256 ccf7b24e51b3ad7b30a8d370f634351ff66044c220dd0c0a461d75247ee33bfe
+MISC ChangeLog 350 RMD160 4e7164b824d76fc5021570bb4fb90795f44e7154 SHA1 297c15f53aa5ea50c212f3ce734ad815c5960c3c SHA256 65dd1a910ea291a40408e5a4124b3d106a99a10faeee8f3aed2374648ef6f183
+MISC metadata.xml 290 RMD160 a31bb9468300ba7321320de317d3130291b7b156 SHA1 69a4c0e652258ebc2bc5da5df525bad3923ebc7f SHA256 69e4f84c4ff607b175fad5627e93fbcd02c729b7df2b5f759b256bbc07092527
diff --git a/dev-libs/xml-security-c/metadata.xml b/dev-libs/xml-security-c/metadata.xml
new file mode 100644
index 000000000..d2a0055ae
--- /dev/null
+++ b/dev-libs/xml-security-c/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+ <use>
+ <flag name='xalan'>Enable support for XSLT and XPath parsing
+ by <pkg>dev-libs/xalan-c</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-libs/xml-security-c/xml-security-c-1.4.0.ebuild b/dev-libs/xml-security-c/xml-security-c-1.4.0.ebuild
new file mode 100644
index 000000000..70800fd12
--- /dev/null
+++ b/dev-libs/xml-security-c/xml-security-c-1.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Apache C++ XML security libraries."
+HOMEPAGE="http://santuario.apache.org/"
+SRC_URI="http://xml.apache.org/security/dist/c-library/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="xalan"
+
+RDEPEND="dev-libs/xerces-c
+ xalan? ( dev-libs/xalan-c )
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile () {
+ econf $(use_with xalan)
+ emake || die "emake failed"
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die "emake failed"
+}