summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-02-07 23:56:26 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-02-07 23:56:26 +0000
commite622dec2d6d1fe06828e1f37a97e4ab6b558acc6 (patch)
tree26e83e82b482637f7403e51bb0de5ad37852a9d9 /dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild
parentdev-python/pyyaml: Added libyaml support and patch. Added correct PYTHON_MODN... (diff)
downloadsunrise-e622dec2d6d1fe06828e1f37a97e4ab6b558acc6.tar.gz
sunrise-e622dec2d6d1fe06828e1f37a97e4ab6b558acc6.tar.bz2
sunrise-e622dec2d6d1fe06828e1f37a97e4ab6b558acc6.zip
dev-python/python-libtorrent: Added NEED_PYTHON instead of dev-lang/python in DEPEND
svn path=/sunrise/; revision=2956
Diffstat (limited to 'dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild')
-rw-r--r--dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild b/dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild
index cb010db0e..fce35ea8d 100644
--- a/dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild
+++ b/dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+NEED_PYTHON=2.3
+
inherit distutils
DESCRIPTION="Python bindings for rb_libtorrent"
@@ -9,13 +11,12 @@ HOMEPAGE="http://deluge-torrent.org"
SRC_URI="http://deluge-torrent.org/downloads/${PN}_${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="~amd64 ~x86"
IUSE=""
-S="${WORKDIR}/${PN}"
-DEPEND=">=dev-lang/python-2.3
- dev-libs/boost"
+S=${WORKDIR}/${PN}
+
+DEPEND="dev-libs/boost"
RDEPEND="${DEPEND}"
pkg_setup() {