summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-07-03 13:51:59 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-07-03 13:51:59 +0000
commit9536b654c3d235f114e51f8addfae3c330183d4c (patch)
tree7d90376537d1bb6f6078b3d02a120498398988cf /dev-util/uno/uno-2.9.ebuild
parentdev-python/buzhug: New ebuild for bug 138267 (diff)
downloadsunrise-9536b654c3d235f114e51f8addfae3c330183d4c.tar.gz
sunrise-9536b654c3d235f114e51f8addfae3c330183d4c.tar.bz2
sunrise-9536b654c3d235f114e51f8addfae3c330183d4c.zip
dev-util/uno: New ebuild for bug 108753
svn path=/sunrise/; revision=454
Diffstat (limited to 'dev-util/uno/uno-2.9.ebuild')
-rw-r--r--dev-util/uno/uno-2.9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/uno/uno-2.9.ebuild b/dev-util/uno/uno-2.9.ebuild
new file mode 100644
index 000000000..5a9db232d
--- /dev/null
+++ b/dev-util/uno/uno-2.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="A simple tool for source code analysis"
+HOMEPAGE="http://spinroot.com/uno"
+SRC_URI="http://spinroot.com/${PN}/${PN}_v${PV/./}.tar.gz"
+
+LICENSE="public-domain GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${PV}-makefile.patch"
+}
+
+src_compile() {
+ cd "${S}/src"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin src/uno src/uno_local src/uno_global
+ doman doc/uno.1
+ insinto "/usr/share/doc/${PF}"
+ doins doc/uno_long.pdf doc/uno_short.pdf
+ insinto "/usr/share/${PN}"
+ doins -r prop
+}