summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/uno/uno-2.9.ebuild')
-rw-r--r--dev-util/uno/uno-2.9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/uno/uno-2.9.ebuild b/dev-util/uno/uno-2.9.ebuild
new file mode 100644
index 000000000..5a9db232d
--- /dev/null
+++ b/dev-util/uno/uno-2.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="A simple tool for source code analysis"
+HOMEPAGE="http://spinroot.com/uno"
+SRC_URI="http://spinroot.com/${PN}/${PN}_v${PV/./}.tar.gz"
+
+LICENSE="public-domain GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${PV}-makefile.patch"
+}
+
+src_compile() {
+ cd "${S}/src"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin src/uno src/uno_local src/uno_global
+ doman doc/uno.1
+ insinto "/usr/share/doc/${PF}"
+ doins doc/uno_long.pdf doc/uno_short.pdf
+ insinto "/usr/share/${PN}"
+ doins -r prop
+}