summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGökdeniz Karadağ (hayalci) <gokdenizk@gmail.com>2008-11-30 21:31:51 +0000
committerGökdeniz Karadağ (hayalci) <gokdenizk@gmail.com>2008-11-30 21:31:51 +0000
commit836ff4ff3046737efcd4b1fbcf30414f5fd8b4a8 (patch)
tree505e92351ca0bd27ab6e25e94bc2e9928afb0cc6 /www-apps/phpMyProxy/phpMyProxy-1.0.3.ebuild
parentnet-misc/anyremote: Drop default src_unpack (diff)
downloadsunrise-836ff4ff3046737efcd4b1fbcf30414f5fd8b4a8.tar.gz
sunrise-836ff4ff3046737efcd4b1fbcf30414f5fd8b4a8.tar.bz2
sunrise-836ff4ff3046737efcd4b1fbcf30414f5fd8b4a8.zip
www-apps/phpMyProxy: New ebuild for phpMyAdmin. Thanks to dleverton, zlin, pva, scarabeus, Tommy[D], omp for review and general help about sunrise. Bug #249411
svn path=/sunrise/; revision=7423
Diffstat (limited to 'www-apps/phpMyProxy/phpMyProxy-1.0.3.ebuild')
-rw-r--r--www-apps/phpMyProxy/phpMyProxy-1.0.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/www-apps/phpMyProxy/phpMyProxy-1.0.3.ebuild b/www-apps/phpMyProxy/phpMyProxy-1.0.3.ebuild
new file mode 100644
index 000000000..0c73ffcab
--- /dev/null
+++ b/www-apps/phpMyProxy/phpMyProxy-1.0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit webapp depend.php
+
+DESCRIPTION="phpMyProxy is a web-based proxy script in PHP"
+HOMEPAGE="http://www.phpmyproxy.com/"
+# Upstream hosts source files as an attachment in a _password protected forum_
+SRC_URI="http://omploader.org/vejZx/${P/-/_}.zip"
+
+LICENSE="GPL-3"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}/${P/-/_}
+
+need_php_httpd
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ require_php_with_use curl
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README.txt TODO.txt CHANGELOG.txt || die "Cannot copy documentation"
+ rm -f README.txt TODO.txt CHANGELOG.txt UPGRADE.txt \
+ || die "Cannot delete copied documentattion"
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r . || die "Cannot copy program files"
+ keepdir "${MY_HTDOCSDIR}"/cookies || die "Cannot create cookies directory"
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/cookies
+ webapp_serverowned "${MY_HTDOCSDIR}"/curl_log.txt
+
+ webapp_configfile "${MY_HTDOCSDIR}"/proxy.config.php
+
+ #webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ #webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}