summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2006-08-12 18:55:32 +0000
committerCédric Krier <cedk@gentoo.org>2006-08-12 18:55:32 +0000
commitdff669dca3c9fd18eaf4168fe60b0a8135a0a4dd (patch)
tree82eaddb2582790830749a1516f10e05445af4b29 /x11-misc/xorg-edit/xorg-edit-06.08.02.ebuild
parentudept is now in portage (diff)
downloadsunrise-dff669dca3c9fd18eaf4168fe60b0a8135a0a4dd.tar.gz
sunrise-dff669dca3c9fd18eaf4168fe60b0a8135a0a4dd.tar.bz2
sunrise-dff669dca3c9fd18eaf4168fe60b0a8135a0a4dd.zip
x11-misc/xorg-edit: Version bump
svn path=/sunrise/; revision=866
Diffstat (limited to 'x11-misc/xorg-edit/xorg-edit-06.08.02.ebuild')
-rw-r--r--x11-misc/xorg-edit/xorg-edit-06.08.02.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/xorg-edit/xorg-edit-06.08.02.ebuild b/x11-misc/xorg-edit/xorg-edit-06.08.02.ebuild
new file mode 100644
index 000000000..acfadb4bf
--- /dev/null
+++ b/x11-misc/xorg-edit/xorg-edit-06.08.02.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="GUI to edit XServer-file xorg.conf easily"
+HOMEPAGE="http://www.cyskat.de/dee/progxorg.htm"
+SRC_URI="mirror://sourceforge/xorg-edit/${PN}_${PV}_src.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/wxGTK-2.6"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ cd sources
+ emake CXX=$(tc-getCXX) || die "emake failed"
+}
+
+src_install() {
+ dobin sources/xorg-edit
+ dodoc changelog.txt readme.txt
+}