summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xorg-edit/xorg-edit-06.08.02.ebuild')
-rw-r--r--x11-misc/xorg-edit/xorg-edit-06.08.02.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/xorg-edit/xorg-edit-06.08.02.ebuild b/x11-misc/xorg-edit/xorg-edit-06.08.02.ebuild
new file mode 100644
index 000000000..acfadb4bf
--- /dev/null
+++ b/x11-misc/xorg-edit/xorg-edit-06.08.02.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="GUI to edit XServer-file xorg.conf easily"
+HOMEPAGE="http://www.cyskat.de/dee/progxorg.htm"
+SRC_URI="mirror://sourceforge/xorg-edit/${PN}_${PV}_src.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/wxGTK-2.6"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ cd sources
+ emake CXX=$(tc-getCXX) || die "emake failed"
+}
+
+src_install() {
+ dobin sources/xorg-edit
+ dodoc changelog.txt readme.txt
+}