summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/samnmax-demo/samnmax-demo-1.ebuild')
-rw-r--r--games-rpg/samnmax-demo/samnmax-demo-1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-rpg/samnmax-demo/samnmax-demo-1.ebuild b/games-rpg/samnmax-demo/samnmax-demo-1.ebuild
new file mode 100644
index 000000000..4d76cfeac
--- /dev/null
+++ b/games-rpg/samnmax-demo/samnmax-demo-1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils games
+
+DESCRIPTION="Sam & Max Hit the Road (interactive demo)"
+HOMEPAGE="http://www.samandmax.net/?section=hittheroad"
+SRC_URI="http://gentooexperimental.org/~unlord/${PN}.rar"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND=">=games-engines/scummvm-0.8.2"
+DEPEND="|| (
+ app-arch/unrar
+ app-arch/rar )"
+
+S=${WORKDIR}
+dir=${GAMES_DATADIR}/${PN}
+
+src_install() {
+ insinto "${dir}"
+ doins SNMDEMO.{SM0,SM1} MONSTER.SOU || die "doins failed"
+
+ games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" samnmax"
+ doicon "${FILESDIR}/${PN}.png" || die "doicon failed"
+ make_desktop_entry ${PN} "Sam & Max Hit the Road (Demo)" ${PN}.png
+
+ prepgamesdirs
+}