summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ArpON/ArpON-1.72.ebuild')
-rw-r--r--net-analyzer/ArpON/ArpON-1.72.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/ArpON/ArpON-1.72.ebuild b/net-analyzer/ArpON/ArpON-1.72.ebuild
new file mode 100644
index 000000000..fa150867a
--- /dev/null
+++ b/net-analyzer/ArpON/ArpON-1.72.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=1
+
+DESCRIPTION="ArpON (Arp handler inspectiON) is a portable Arp handler."
+
+HOMEPAGE="http://arpon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arpon/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libdnet
+ net-libs/libnet:1.1
+ net-libs/libpcap"
+
+RDEPEND=${DEPEND}
+
+src_compile() {
+ emake gentoo || die "emake Gentoo failed"
+}
+
+src_install() {
+ dosbin arpon || die "arpon installation failed"
+ doman man8/arpon.8 || die "arpon man installation failed"
+ dodoc AUTHORS CHANGELOG TODO || die "arpon doc instalation failed"
+}