summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2012-05-24 13:32:02 -0400
committerVadim Kuznetsov <vadimk@gentoo.org>2012-05-24 13:32:02 -0400
commit901aff71742e0d2d141d254238bf753e448a9ed6 (patch)
tree3b6161a9d280f9d8f12cf705585734784c4eb536 /app-emulation/vmware-modules/files
parentd_make_root patch for 3.4 kernel. Bug 411853. (diff)
downloadvmware-901aff71742e0d2d141d254238bf753e448a9ed6.tar.gz
vmware-901aff71742e0d2d141d254238bf753e448a9ed6.tar.bz2
vmware-901aff71742e0d2d141d254238bf753e448a9ed6.zip
Andrew Dean's patch of 238 vmware modules for 3.4.0 kernel
new file: files/238-d-make-root.patch modified: vmware-modules-238.5-r1.ebuild
Diffstat (limited to 'app-emulation/vmware-modules/files')
-rw-r--r--app-emulation/vmware-modules/files/238-d-make-root.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/app-emulation/vmware-modules/files/238-d-make-root.patch b/app-emulation/vmware-modules/files/238-d-make-root.patch
new file mode 100644
index 0000000..7e83a1e
--- /dev/null
+++ b/app-emulation/vmware-modules/files/238-d-make-root.patch
@@ -0,0 +1,14 @@
+--- a/vmblock-only/linux/filesystem.c 2012-05-23 20:08:00.632051396 -0500
++++ b/vmblock-only/linux/filesystem.c 2012-05-23 20:17:00.896297163 -0500
+@@ -517,7 +517,11 @@
+ return -EINVAL;
+ }
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 4, 0)
+ rootDentry = d_alloc_root(rootInode);
++#else
++ rootDentry = d_make_root(rootInode);
++#endif
+ if (!rootDentry) {
+ iput(rootInode);
+ return -ENOMEM;