summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEvan Teran <evan.teran@gmail.com>2014-10-11 11:47:01 -0400
committerEvan Teran <evan.teran@gmail.com>2014-10-11 11:47:01 -0400
commit87ec4f2abfca54db62bfa89450aa1c55a2e5d9b5 (patch)
treeaecdb7353de127c132a7c2e68d7d0c3efd2f9403 /app-emulation/vmware-modules
parentnow supports 3.13.0 (diff)
downloadvmware-87ec4f2abfca54db62bfa89450aa1c55a2e5d9b5.tar.gz
vmware-87ec4f2abfca54db62bfa89450aa1c55a2e5d9b5.tar.bz2
vmware-87ec4f2abfca54db62bfa89450aa1c55a2e5d9b5.zip
build on 3.14.0
Diffstat (limited to 'app-emulation/vmware-modules')
-rw-r--r--app-emulation/vmware-modules/files/279-3.10-03-deprecated.patch85
-rw-r--r--app-emulation/vmware-modules/files/279-3.10-04-dentry.patch (renamed from app-emulation/vmware-modules/files/279-3.10-03-dentry.patch)0
-rw-r--r--app-emulation/vmware-modules/files/279-3.10-05-inode.patch (renamed from app-emulation/vmware-modules/files/279-3.10-04-inode.patch)0
-rw-r--r--app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild5
4 files changed, 88 insertions, 2 deletions
diff --git a/app-emulation/vmware-modules/files/279-3.10-03-deprecated.patch b/app-emulation/vmware-modules/files/279-3.10-03-deprecated.patch
new file mode 100644
index 0000000..3a9f785
--- /dev/null
+++ b/app-emulation/vmware-modules/files/279-3.10-03-deprecated.patch
@@ -0,0 +1,85 @@
+diff -rupN vmblock-only/shared/vm_assert.h vmblock-only.new/shared/vm_assert.h
+--- vmblock-only/shared/vm_assert.h 2014-10-09 21:50:54.221159088 -0400
++++ vmblock-only.new/shared/vm_assert.h 2014-10-09 21:53:04.612166156 -0400
+@@ -237,11 +237,13 @@ EXTERN void WarningThrottled(uint32 *cou
+ #define LOG_ONCE(_s) DO_ONCE(Log _s)
+
+ #ifdef VMX86_DEVEL
++ #undef DEPRECATED
+ #define DEPRECATED(_fix) DO_ONCE( \
+ Warning("%s:%d: %s is DEPRECATED; %s\n", \
+ __FILE__, __LINE__, __FUNCTION__, \
+ _fix))
+ #else
++ #undef DEPRECATED
+ #define DEPRECATED(_fix) do {} while (0)
+ #endif
+
+diff -rupN vmci-only/shared/vm_assert.h vmci-only.new/shared/vm_assert.h
+--- vmci-only/shared/vm_assert.h 2014-10-09 21:50:54.222159088 -0400
++++ vmci-only.new/shared/vm_assert.h 2014-10-09 21:52:52.348165492 -0400
+@@ -237,11 +237,13 @@ EXTERN void WarningThrottled(uint32 *cou
+ #define LOG_ONCE(_s) DO_ONCE(Log _s)
+
+ #ifdef VMX86_DEVEL
++ #undef DEPRECATED
+ #define DEPRECATED(_fix) DO_ONCE( \
+ Warning("%s:%d: %s is DEPRECATED; %s\n", \
+ __FILE__, __LINE__, __FUNCTION__, \
+ _fix))
+ #else
++ #undef DEPRECATED
+ #define DEPRECATED(_fix) do {} while (0)
+ #endif
+
+diff -rupN vmmon-only/include/vm_assert.h vmmon-only.new/include/vm_assert.h
+--- vmmon-only/include/vm_assert.h 2014-10-09 21:50:54.222159088 -0400
++++ vmmon-only.new/include/vm_assert.h 2014-10-09 21:52:36.877164653 -0400
+@@ -237,11 +237,13 @@ EXTERN void WarningThrottled(uint32 *cou
+ #define LOG_ONCE(_s) DO_ONCE(Log _s)
+
+ #ifdef VMX86_DEVEL
++ #undef DEPRECATED
+ #define DEPRECATED(_fix) DO_ONCE( \
+ Warning("%s:%d: %s is DEPRECATED; %s\n", \
+ __FILE__, __LINE__, __FUNCTION__, \
+ _fix))
+ #else
++ #undef DEPRECATED
+ #define DEPRECATED(_fix) do {} while (0)
+ #endif
+
+diff -rupN vmnet-only/vm_assert.h vmnet-only.new/vm_assert.h
+--- vmnet-only/vm_assert.h 2014-10-09 21:50:54.222159088 -0400
++++ vmnet-only.new/vm_assert.h 2014-10-09 21:52:57.736165784 -0400
+@@ -237,11 +237,13 @@ EXTERN void WarningThrottled(uint32 *cou
+ #define LOG_ONCE(_s) DO_ONCE(Log _s)
+
+ #ifdef VMX86_DEVEL
++ #undef DEPRECATED
+ #define DEPRECATED(_fix) DO_ONCE( \
+ Warning("%s:%d: %s is DEPRECATED; %s\n", \
+ __FILE__, __LINE__, __FUNCTION__, \
+ _fix))
+ #else
++ #undef DEPRECATED
+ #define DEPRECATED(_fix) do {} while (0)
+ #endif
+
+diff -rupN vsock-only/shared/vm_assert.h vsock-only.new/shared/vm_assert.h
+--- vsock-only/shared/vm_assert.h 2014-10-09 21:50:54.222159088 -0400
++++ vsock-only.new/shared/vm_assert.h 2014-10-09 21:52:45.352165112 -0400
+@@ -237,11 +237,13 @@ EXTERN void WarningThrottled(uint32 *cou
+ #define LOG_ONCE(_s) DO_ONCE(Log _s)
+
+ #ifdef VMX86_DEVEL
++ #undef DEPRECATED
+ #define DEPRECATED(_fix) DO_ONCE( \
+ Warning("%s:%d: %s is DEPRECATED; %s\n", \
+ __FILE__, __LINE__, __FUNCTION__, \
+ _fix))
+ #else
++ #undef DEPRECATED
+ #define DEPRECATED(_fix) do {} while (0)
+ #endif
+
diff --git a/app-emulation/vmware-modules/files/279-3.10-03-dentry.patch b/app-emulation/vmware-modules/files/279-3.10-04-dentry.patch
index 8acecf5..8acecf5 100644
--- a/app-emulation/vmware-modules/files/279-3.10-03-dentry.patch
+++ b/app-emulation/vmware-modules/files/279-3.10-04-dentry.patch
diff --git a/app-emulation/vmware-modules/files/279-3.10-04-inode.patch b/app-emulation/vmware-modules/files/279-3.10-05-inode.patch
index 0d30dbe..0d30dbe 100644
--- a/app-emulation/vmware-modules/files/279-3.10-04-inode.patch
+++ b/app-emulation/vmware-modules/files/279-3.10-05-inode.patch
diff --git a/app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild b/app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild
index cd4419a..131d93a 100644
--- a/app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild
@@ -83,8 +83,9 @@ src_prepare() {
kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10-00-userns.patch"
kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10-01-getname.patch"
kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10-02-unused-typedef.patch"
- kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10-03-dentry.patch"
- kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10-04-inode.patch"
+ kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10-03-deprecated.patch"
+ kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10-04-dentry.patch"
+ kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10-05-inode.patch"
# fixes a memcpy/memcmp bug in the hub code
kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10-05-hub.patch"