summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-04-27 05:11:33 -0500
committerBen Kohler <bkohler@gentoo.org>2024-04-27 05:19:08 -0500
commit59ff612b8c9447492a9c6704779be7e83b0b928c (patch)
tree6030e942fdc195a35a229a0ffaf054e0ee90f69f
parentnet-irc/ircii: drop 20210314-r2, 20221016, 20230930 (diff)
downloadgentoo-master.tar.gz
gentoo-master.tar.bz2
gentoo-master.zip
dev-libs/newt: drop 0.52.23, 0.52.23-r1HEADmaster
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--dev-libs/newt/Manifest1
-rw-r--r--dev-libs/newt/files/newt-0.52.14-tcl.patch108
-rw-r--r--dev-libs/newt/files/newt-0.52.22-gold.patch13
-rw-r--r--dev-libs/newt/newt-0.52.23-r1.ebuild102
-rw-r--r--dev-libs/newt/newt-0.52.23.ebuild103
5 files changed, 0 insertions, 327 deletions
diff --git a/dev-libs/newt/Manifest b/dev-libs/newt/Manifest
index 78e8d9dbbf42..397932fcbcff 100644
--- a/dev-libs/newt/Manifest
+++ b/dev-libs/newt/Manifest
@@ -1,2 +1 @@
-DIST newt-0.52.23.tar.gz 128884 BLAKE2B 283809ac259475588b2f277e6c14ddc2981204f8d6c4963aa9ca7bf87376d2025e9edcc3194804bd6928f75deef706758e1868ba730fd06856ed0a95e534be00 SHA512 8040b01178311532c31642daae5bffc9c0f1917d28957164a02b3f5bd402e6561ff6faee75a936f72485eb71004238ede78c1973a970451fb5aaccff231887c7
DIST newt-0.52.24.tar.gz 128895 BLAKE2B fff7b3831f53a33b2d4f009fae0eb5603aef79c50f89e7f7179b80be837db35e44ecc860e4dc85e46195a59a87c12b2feae2ab043bef2fee0ea35a6efeded474 SHA512 999d8109dd3d74d04e813e84dc2e348278016dce7a678a1566197cf8fbc87810257b8a29fa766d29d48dc18bf4e1508b022460f15503fb6d029b3a05528b50be
diff --git a/dev-libs/newt/files/newt-0.52.14-tcl.patch b/dev-libs/newt/files/newt-0.52.14-tcl.patch
deleted file mode 100644
index 4e10d2baae9e..000000000000
--- a/dev-libs/newt/files/newt-0.52.14-tcl.patch
+++ /dev/null
@@ -1,108 +0,0 @@
-diff --git a/whiptcl.c b/whiptcl.c
-index 8688780..7219911 100644
---- a/whiptcl.c
-+++ b/whiptcl.c
-@@ -137,45 +137,45 @@ static int wtCmd(ClientData clientData, Tcl_Interp * interp, int argc,
-
- if (arg < -1) {
- /* this could buffer oveflow, bug we're not setuid so I don't care */
-- interp->result = malloc(200);
-- interp->freeProc = TCL_DYNAMIC;
-- sprintf(interp->result, "%s: %s\n",
-+ char *tmp = malloc(200);
-+ sprintf(tmp, "%s: %s\n",
- poptBadOption(optCon, POPT_BADOPTION_NOALIAS),
- poptStrerror(arg));
-+ Tcl_SetResult(interp, tmp, TCL_DYNAMIC);
-
- return TCL_ERROR;
- }
-
- if (mode == MODE_NONE) {
-- interp->result = "no dialog mode was specified";
-+ Tcl_SetResultString(interp, "no dialog mode was specified");
- return TCL_ERROR;
- } else if (rc) {
-- interp->result = "multiple modes were specified";
-+ Tcl_SetResultString(interp, "multiple modes were specified");
- return TCL_ERROR;
- }
-
- if (!(text = poptGetArg(optCon))) {
-- interp->result = "missing text parameter";
-+ Tcl_SetResultString(interp, "missing text parameter");
- return TCL_ERROR;
- }
-
- if (!(nextArg = poptGetArg(optCon))) {
-- interp->result = "height missing";
-+ Tcl_SetResultString(interp, "height missing");
- return TCL_ERROR;
- }
- height = strtoul(nextArg, &end, 10);
- if (*end) {
-- interp->result = "height is not a number";
-+ Tcl_SetResultString(interp, "height is not a number");
- return TCL_ERROR;
- }
-
- if (!(nextArg = poptGetArg(optCon))) {
-- interp->result = "width missing";
-+ Tcl_SetResultString(interp, "width missing");
- return TCL_ERROR;
- }
- width = strtoul(nextArg, &end, 10);
- if (*end) {
-- interp->result = "width is not a number";
-+ Tcl_SetResultString(interp, "width is not a number");
- return TCL_ERROR;
- }
-
-@@ -196,33 +196,30 @@ static int wtCmd(ClientData clientData, Tcl_Interp * interp, int argc,
- case MODE_YESNO:
- rc = messageBox(text, height, width, MSGBOX_YESNO, flags);
- if (rc == DLG_OKAY)
-- interp->result = "yes";
-+ Tcl_SetResultString(interp, "yes");
- else
-- interp->result = "no";
-+ Tcl_SetResultString(interp, "no");
- if (rc == DLG_ERROR) rc = 0;
- break;
-
- case MODE_INPUTBOX:
- rc = inputBox(text, height, width, optCon, flags, &result);
- if (rc ==DLG_OKAY) {
-- interp->result = result;
-- interp->freeProc = TCL_DYNAMIC;
-+ Tcl_SetResult(interp, result, TCL_DYNAMIC);
- }
- break;
-
- case MODE_MENU:
- rc = listBox(text, height, width, optCon, flags, default_item, &result);
- if (rc==DLG_OKAY) {
-- interp->result = result;
-- interp->freeProc = TCL_DYNAMIC;
-+ Tcl_SetResult(interp, result, TCL_DYNAMIC);
- }
- break;
-
- case MODE_RADIOLIST:
- rc = checkList(text, height, width, optCon, 1, flags, &selections);
- if (rc==DLG_OKAY) {
-- interp->result = selections[0];
-- interp->freeProc = TCL_DYNAMIC;
-+ Tcl_SetResult(interp, selections[0], TCL_DYNAMIC);
-
- free(selections);
- }
-@@ -247,7 +244,7 @@ static int wtCmd(ClientData clientData, Tcl_Interp * interp, int argc,
- newtPopWindow();
-
- if (rc == DLG_ERROR) {
-- interp->result = "bad paramter for whiptcl dialog box";
-+ Tcl_SetResultString(interp, "bad paramter for whiptcl dialog box");
- return TCL_ERROR;
- }
-
diff --git a/dev-libs/newt/files/newt-0.52.22-gold.patch b/dev-libs/newt/files/newt-0.52.22-gold.patch
deleted file mode 100644
index add9ce872dfd..000000000000
--- a/dev-libs/newt/files/newt-0.52.22-gold.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -ur a/configure.ac b/configure.ac
---- a/configure.ac 2022-11-21 07:58:11.000000000 -0600
-+++ b/configure.ac 2022-11-21 20:56:42.211913050 -0600
-@@ -24,7 +24,8 @@
- AC_MSG_CHECKING([for GNU ld])
- LD=$($CC -print-prog-name=ld 2>&5)
-
--if test $($LD -v 2>&1 | $ac_cv_path_GREP -c "GNU ld") = 0; then
-+if test $($LD -v 2>&1 | $ac_cv_path_GREP -c "GNU ld") = 0 -a \
-+ test $($LD -v 2>&1 | $ac_cv_path_GREP -c "GNU gold") = 0; then
- # Not
- GNU_LD=""
- AC_MSG_RESULT([no])
diff --git a/dev-libs/newt/newt-0.52.23-r1.ebuild b/dev-libs/newt/newt-0.52.23-r1.ebuild
deleted file mode 100644
index 14380493db38..000000000000
--- a/dev-libs/newt/newt-0.52.23-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit autotools python-r1 toolchain-funcs
-
-MY_PV="r$(ver_rs 1- -)"
-
-DESCRIPTION="Redhat's Newt windowing toolkit development files"
-HOMEPAGE="https://pagure.io/newt"
-SRC_URI="https://github.com/mlichvar/newt/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
-IUSE="gpm nls tcl"
-RESTRICT="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-libs/popt-1.6
- =sys-libs/slang-2*
- gpm? ( sys-libs/gpm )
- tcl? ( >=dev-lang/tcl-8.5:0 )
- "
-DEPEND="${RDEPEND}"
-BDEPEND="sys-devel/gettext"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.52.23-gold.patch
- "${FILESDIR}"/${PN}-0.52.21-python-sitedir.patch
-)
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-src_prepare() {
- sed -i Makefile.in \
- -e 's|$(SHCFLAGS) -o|$(LDFLAGS) &|g' \
- -e 's|-g -o|$(CFLAGS) $(LDFLAGS) -o|g' \
- -e 's|-shared -o|$(CFLAGS) $(LDFLAGS) &|g' \
- -e 's|instroot|DESTDIR|g' \
- -e 's| make | $(MAKE) |g' \
- -e "s| ar | $(tc-getAR) |g" \
- || die "sed Makefile.in"
-
- if [[ -n ${LINGUAS} ]]; then
- local lang langs
- for lang in ${LINGUAS}; do
- test -r po/${lang}.po && langs="${langs} ${lang}.po"
- done
- sed -i po/Makefile \
- -e "/^CATALOGS = /cCATALOGS = ${langs}" \
- || die "sed po/Makefile"
- fi
-
- default
- eautoreconf
-
- # can't build out-of-source
- python_copy_sources
-}
-
-src_configure() {
- configuring() {
- econf \
- PYTHONVERS="${PYTHON}" \
- $(use_with gpm gpm-support) \
- $(use_with tcl) \
- $(use_enable nls)
- }
- python_foreach_impl run_in_build_dir configuring
-}
-
-src_compile() {
- building() {
- emake PYTHONVERS="${EPYTHON}"
- }
- python_foreach_impl run_in_build_dir building
-}
-
-src_install() {
- installit() {
- emake \
- DESTDIR="${D}" \
- PYTHON_SITEDIR="$(python_get_sitedir)" \
- PYTHONVERS="${EPYTHON}" \
- install
- python_optimize
- }
- python_foreach_impl run_in_build_dir installit
- dodoc peanuts.py popcorn.py tutorial.sgml
- doman whiptail.1
- einstalldocs
-
- # don't want static archives
- rm "${ED}"/usr/$(get_libdir)/libnewt.a || die
-}
diff --git a/dev-libs/newt/newt-0.52.23.ebuild b/dev-libs/newt/newt-0.52.23.ebuild
deleted file mode 100644
index f4565ff37ed1..000000000000
--- a/dev-libs/newt/newt-0.52.23.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit autotools python-r1 toolchain-funcs
-
-MY_PV="r$(ver_rs 1- -)"
-
-DESCRIPTION="Redhat's Newt windowing toolkit development files"
-HOMEPAGE="https://pagure.io/newt"
-SRC_URI="https://github.com/mlichvar/newt/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
-IUSE="gpm nls tcl"
-RESTRICT="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-libs/popt-1.6
- =sys-libs/slang-2*
- gpm? ( sys-libs/gpm )
- tcl? ( >=dev-lang/tcl-8.5:0 )
- "
-DEPEND="${RDEPEND}"
-BDEPEND="sys-devel/gettext"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.52.22-gold.patch
-# "${FILESDIR}"/${PN}-0.52.14-tcl.patch
- "${FILESDIR}"/${PN}-0.52.21-python-sitedir.patch
-)
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-src_prepare() {
- sed -i Makefile.in \
- -e 's|$(SHCFLAGS) -o|$(LDFLAGS) &|g' \
- -e 's|-g -o|$(CFLAGS) $(LDFLAGS) -o|g' \
- -e 's|-shared -o|$(CFLAGS) $(LDFLAGS) &|g' \
- -e 's|instroot|DESTDIR|g' \
- -e 's| make | $(MAKE) |g' \
- -e "s| ar | $(tc-getAR) |g" \
- || die "sed Makefile.in"
-
- if [[ -n ${LINGUAS} ]]; then
- local lang langs
- for lang in ${LINGUAS}; do
- test -r po/${lang}.po && langs="${langs} ${lang}.po"
- done
- sed -i po/Makefile \
- -e "/^CATALOGS = /cCATALOGS = ${langs}" \
- || die "sed po/Makefile"
- fi
-
- default
- eautoreconf
-
- # can't build out-of-source
- python_copy_sources
-}
-
-src_configure() {
- configuring() {
- econf \
- PYTHONVERS="${PYTHON}" \
- $(use_with gpm gpm-support) \
- $(use_with tcl) \
- $(use_enable nls)
- }
- python_foreach_impl run_in_build_dir configuring
-}
-
-src_compile() {
- building() {
- emake PYTHONVERS="${EPYTHON}"
- }
- python_foreach_impl run_in_build_dir building
-}
-
-src_install() {
- installit() {
- emake \
- DESTDIR="${D}" \
- PYTHON_SITEDIR="$(python_get_sitedir)" \
- PYTHONVERS="${EPYTHON}" \
- install
- python_optimize
- }
- python_foreach_impl run_in_build_dir installit
- dodoc peanuts.py popcorn.py tutorial.sgml
- doman whiptail.1
- einstalldocs
-
- # don't want static archives
- rm "${ED}"/usr/$(get_libdir)/libnewt.a || die
-}