summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-wm/wayfire/metadata.xml6
-rw-r--r--gui-wm/wayfire/wayfire-0.8.0-r2.ebuild4
-rw-r--r--gui-wm/wayfire/wayfire-0.8.1-r1.ebuild4
-rw-r--r--gui-wm/wayfire/wayfire-9999.ebuild4
4 files changed, 10 insertions, 8 deletions
diff --git a/gui-wm/wayfire/metadata.xml b/gui-wm/wayfire/metadata.xml
index b7ebd8524caf..fb1df8affac5 100644
--- a/gui-wm/wayfire/metadata.xml
+++ b/gui-wm/wayfire/metadata.xml
@@ -9,8 +9,10 @@
</longdescription>
<use>
<flag name="gles">use libglvnd to do animations more efficiently</flag>
- <flag name="system-wfconfig">use the system-wide wf-config, else build it as a submodule. DO NOT DISABLE UNLESS YOU KNOW WHAT YOU ARE DOING.</flag>
- <flag name="system-wlroots">use the system wide wlroots, else build it as a submodule. DO NOT DISABLE UNLESS YOU KNOW WHAT YOU ARE DOING.</flag>
+ <flag name="gles3">Enable OpenGL ES 3.x Features.</flag>
+ <flag name="system-wfconfig">Use the system-wide <pkg>gui-libs/wf-config</pkg> instead of building as a submodule. It will block system-wide <pkg>gui-libs/wf-config</pkg> from being installed.</flag>
+ <flag name="system-wlroots">Use the system-wide <pkg>gui-libs/wlroots</pkg> instead of building as a submodule. It will block system-wide <pkg>gui-libs/wlroots</pkg> from being installed.</flag>
+ <flag name="X">Enable support for X11 applications (XWayland).</flag>
</use>
<upstream>
<remote-id type="github">WayfireWM/wayfire</remote-id>
diff --git a/gui-wm/wayfire/wayfire-0.8.0-r2.ebuild b/gui-wm/wayfire/wayfire-0.8.0-r2.ebuild
index c6ed5fedef88..d2c8b090436a 100644
--- a/gui-wm/wayfire/wayfire-0.8.0-r2.ebuild
+++ b/gui-wm/wayfire/wayfire-0.8.0-r2.ebuild
@@ -19,7 +19,7 @@ else
fi
LICENSE="MIT"
-IUSE="+gles +system-wfconfig +system-wlroots test X"
+IUSE="+gles3 +system-wfconfig +system-wlroots test X"
RESTRICT="!test? ( test )"
# bundled wlroots has the following dependency string according to included headers.
@@ -128,7 +128,7 @@ src_configure() {
$(meson_feature system-wlroots use_system_wlroots)
$(meson_feature test tests)
$(meson_feature X xwayland)
- $(meson_use gles enable_gles32)
+ $(meson_use gles3 enable_gles32)
)
meson_src_configure
diff --git a/gui-wm/wayfire/wayfire-0.8.1-r1.ebuild b/gui-wm/wayfire/wayfire-0.8.1-r1.ebuild
index 094395b5b72e..82d800484181 100644
--- a/gui-wm/wayfire/wayfire-0.8.1-r1.ebuild
+++ b/gui-wm/wayfire/wayfire-0.8.1-r1.ebuild
@@ -19,7 +19,7 @@ else
fi
LICENSE="MIT"
-IUSE="+gles test X"
+IUSE="+gles3 test X"
RESTRICT="!test? ( test )"
# bundled wlroots has the following dependency string according to included headers.
@@ -77,7 +77,7 @@ src_configure() {
local emesonargs=(
$(meson_feature test tests)
$(meson_feature X xwayland)
- $(meson_use gles enable_gles32)
+ $(meson_use gles3 enable_gles32)
-Duse_system_wfconfig=enabled
-Duse_system_wlroots=enabled
)
diff --git a/gui-wm/wayfire/wayfire-9999.ebuild b/gui-wm/wayfire/wayfire-9999.ebuild
index 0666f1cd607d..6a2f5696709d 100644
--- a/gui-wm/wayfire/wayfire-9999.ebuild
+++ b/gui-wm/wayfire/wayfire-9999.ebuild
@@ -19,7 +19,7 @@ else
fi
LICENSE="MIT"
-IUSE="+gles test X"
+IUSE="+gles3 test X"
RESTRICT="!test? ( test )"
# bundled wlroots has the following dependency string according to included headers.
@@ -73,7 +73,7 @@ src_configure() {
local emesonargs=(
$(meson_feature test tests)
$(meson_feature X xwayland)
- $(meson_use gles enable_gles32)
+ $(meson_use gles3 enable_gles32)
-Duse_system_wfconfig=enabled
-Duse_system_wlroots=enabled
)