summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-03-26 19:30:23 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-03-26 19:54:10 +0100
commit04480f9a25f44d738dff0e927ba8a09a7bde9d59 (patch)
treeedece34345077f7352b4ab4de5d926ab002db535
parentdev-python/pyalsa: Removed old (diff)
downloadgentoo-04480f9a25f44d738dff0e927ba8a09a7bde9d59.tar.gz
gentoo-04480f9a25f44d738dff0e927ba8a09a7bde9d59.tar.bz2
gentoo-04480f9a25f44d738dff0e927ba8a09a7bde9d59.zip
dev-python/pyalsa: Added more python3 versions
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-python/pyalsa/pyalsa-1.1.6-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pyalsa/pyalsa-1.1.6-r1.ebuild b/dev-python/pyalsa/pyalsa-1.1.6-r1.ebuild
new file mode 100644
index 000000000000..23d841491b61
--- /dev/null
+++ b/dev-python/pyalsa/pyalsa-1.1.6-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python bindings for ALSA library"
+HOMEPAGE="https://alsa-project.org/"
+SRC_URI="https://www.alsa-project.org/files/pub/pyalsa/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${PN}-1.1.6-no-build-symlinks.patch" )
+
+# Testsuite appears to require installed state