summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyalsa/pyalsa-1.1.6-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pyalsa/pyalsa-1.1.6-r1.ebuild b/dev-python/pyalsa/pyalsa-1.1.6-r1.ebuild
new file mode 100644
index 000000000000..23d841491b61
--- /dev/null
+++ b/dev-python/pyalsa/pyalsa-1.1.6-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python bindings for ALSA library"
+HOMEPAGE="https://alsa-project.org/"
+SRC_URI="https://www.alsa-project.org/files/pub/pyalsa/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${PN}-1.1.6-no-build-symlinks.patch" )
+
+# Testsuite appears to require installed state