summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2016-06-08 15:40:38 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-06-08 19:50:40 +0000
commit0ad2107e16f9f5b64b94ebd7bac12d930db4ac12 (patch)
tree10e28412b2dc0bbbb438101f0bdb900bb2e8fbd1
parentdev-tcltk/expect: arm stable, bug #511622 (diff)
downloadgentoo-0ad2107e16f9f5b64b94ebd7bac12d930db4ac12.tar.gz
gentoo-0ad2107e16f9f5b64b94ebd7bac12d930db4ac12.tar.bz2
gentoo-0ad2107e16f9f5b64b94ebd7bac12d930db4ac12.zip
app-benchmarks/sysbench: adding live ebuild
Package-Manager: portage-2.3.0_rc1 Closes: https://github.com/gentoo/gentoo/pull/1628 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--app-benchmarks/sysbench/sysbench-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-benchmarks/sysbench/sysbench-9999.ebuild b/app-benchmarks/sysbench/sysbench-9999.ebuild
new file mode 100644
index 000000000000..e82c950c0233
--- /dev/null
+++ b/app-benchmarks/sysbench/sysbench-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit git-r3
+
+DESCRIPTION="System performance benchmark"
+HOMEPAGE="https://github.com/akopytov/sysbench"
+
+EGIT_REPO_URI="https://github.com/akopytov/sysbench.git"
+EGIT_BRANCH="1.0"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="aio mysql"
+
+DEPEND="aio? ( dev-libs/libaio )
+ mysql? ( virtual/libmysqlclient )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e "/^htmldir =/s:=.*:=/usr/share/doc/${PF}/html:" doc/Makefile.am || die
+
+ ./autogen.sh || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable aio aio)
+ $(use_with mysql mysql)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/${PN}/tests/db
+ doins sysbench/tests/db/*.lua || die
+}