summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-benchmarks/sysbench/sysbench-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-benchmarks/sysbench/sysbench-9999.ebuild b/app-benchmarks/sysbench/sysbench-9999.ebuild
new file mode 100644
index 000000000000..e82c950c0233
--- /dev/null
+++ b/app-benchmarks/sysbench/sysbench-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit git-r3
+
+DESCRIPTION="System performance benchmark"
+HOMEPAGE="https://github.com/akopytov/sysbench"
+
+EGIT_REPO_URI="https://github.com/akopytov/sysbench.git"
+EGIT_BRANCH="1.0"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="aio mysql"
+
+DEPEND="aio? ( dev-libs/libaio )
+ mysql? ( virtual/libmysqlclient )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e "/^htmldir =/s:=.*:=/usr/share/doc/${PF}/html:" doc/Makefile.am || die
+
+ ./autogen.sh || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable aio aio)
+ $(use_with mysql mysql)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/${PN}/tests/db
+ doins sysbench/tests/db/*.lua || die
+}