summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2018-03-17 08:57:47 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-17 09:34:20 +0100
commit27c925f82d0bd84aecb3f1173e36bc02e20fc4e7 (patch)
treeb35ee106a23ff86ed04f672bdc7ae201c3453751
parentdev-perl/Tk-TableMatrix: EAPI6 + tests (diff)
downloadgentoo-27c925f82d0bd84aecb3f1173e36bc02e20fc4e7.tar.gz
gentoo-27c925f82d0bd84aecb3f1173e36bc02e20fc4e7.tar.bz2
gentoo-27c925f82d0bd84aecb3f1173e36bc02e20fc4e7.zip
x11-misc/xkblayout-state: Initial commit
Closes: https://github.com/gentoo/gentoo/pull/6389 Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--x11-misc/xkblayout-state/Manifest1
-rw-r--r--x11-misc/xkblayout-state/metadata.xml12
-rw-r--r--x11-misc/xkblayout-state/xkblayout-state-0_p20180118.ebuild31
-rw-r--r--x11-misc/xkblayout-state/xkblayout-state-9999.ebuild26
4 files changed, 70 insertions, 0 deletions
diff --git a/x11-misc/xkblayout-state/Manifest b/x11-misc/xkblayout-state/Manifest
new file mode 100644
index 000000000000..a23c24b233aa
--- /dev/null
+++ b/x11-misc/xkblayout-state/Manifest
@@ -0,0 +1 @@
+DIST xkblayout-state-0_p20180118.tar.gz 6853 BLAKE2B 1a8b3a9c89d9647bb8b9f6a2261f2e06f44f408823939268d60364fe532b9501e3c36d8f66cc1160f0b5432874d48046f848159842d09135a6cb4af658a8b248 SHA512 7618e920f8044324b7f4eb58d4e22ce076056d2d911cd950e6a862303c4b37f31f5919fec69c63173a7ff181d51849def4f6a78a407baf3012232f2f423bed00
diff --git a/x11-misc/xkblayout-state/metadata.xml b/x11-misc/xkblayout-state/metadata.xml
new file mode 100644
index 000000000000..b5f0b450d001
--- /dev/null
+++ b/x11-misc/xkblayout-state/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>karl.j.linden@gmail.com</email>
+ <name>Karl Linden</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-misc/xkblayout-state/xkblayout-state-0_p20180118.ebuild b/x11-misc/xkblayout-state/xkblayout-state-0_p20180118.ebuild
new file mode 100644
index 000000000000..afbeba66bacf
--- /dev/null
+++ b/x11-misc/xkblayout-state/xkblayout-state-0_p20180118.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+# Commit Date: 18 Jan 2018
+EGIT_COMMIT="45b752b130e077d5b1437d40b0a459e062aafa13"
+
+DESCRIPTION="A small program to get/set the current XKB layout"
+HOMEPAGE="https://github.com/nonpop/xkblayout-state"
+SRC_URI="https://github.com/nonpop/xkblayout-state/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}"/usr DESTDIR="${D}" install
+}
diff --git a/x11-misc/xkblayout-state/xkblayout-state-9999.ebuild b/x11-misc/xkblayout-state/xkblayout-state-9999.ebuild
new file mode 100644
index 000000000000..b92c94a33662
--- /dev/null
+++ b/x11-misc/xkblayout-state/xkblayout-state-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="A small program to get/set the current XKB layout"
+HOMEPAGE="https://github.com/nonpop/xkblayout-state"
+EGIT_REPO_URI="https://github.com/nonpop/xkblayout-state.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}"/usr DESTDIR="${D}" install
+}