summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-20 16:53:01 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-20 18:37:26 +0200
commit567bd949767788d0c1ca82bf998726e50819a6bf (patch)
tree753cfb7cd63084e468a6b4970cbde6c4ae4aec2b
parentsci-calculators/units: [QA] Add missing python metadata variables (diff)
downloadgentoo-567bd949767788d0c1ca82bf998726e50819a6bf.tar.gz
gentoo-567bd949767788d0c1ca82bf998726e50819a6bf.tar.bz2
gentoo-567bd949767788d0c1ca82bf998726e50819a6bf.zip
sci-chemistry/avogadro: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--sci-chemistry/avogadro/avogadro-1.0.3-r2.ebuild6
-rw-r--r--sci-chemistry/avogadro/avogadro-1.1.0.ebuild6
-rw-r--r--sci-chemistry/avogadro/avogadro-1.1.1.ebuild6
3 files changed, 12 insertions, 6 deletions
diff --git a/sci-chemistry/avogadro/avogadro-1.0.3-r2.ebuild b/sci-chemistry/avogadro/avogadro-1.0.3-r2.ebuild
index 8f26039b9b36..07d98f042004 100644
--- a/sci-chemistry/avogadro/avogadro-1.0.3-r2.ebuild
+++ b/sci-chemistry/avogadro/avogadro-1.0.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,17 +15,19 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="+glsl python cpu_flags_x86_sse2"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
>=sci-chemistry/openbabel-2.2.3
>=dev-qt/qtgui-4.5.3:4
>=dev-qt/qtopengl-4.5.3:4
x11-libs/gl2ps
- glsl? ( >=media-libs/glew-1.5.0 )
+ glsl? ( >=media-libs/glew-1.5.0:0= )
python? (
>=dev-libs/boost-1.35.0-r5[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/sip[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
)"
DEPEND="${RDEPEND}
dev-cpp/eigen:2"
diff --git a/sci-chemistry/avogadro/avogadro-1.1.0.ebuild b/sci-chemistry/avogadro/avogadro-1.1.0.ebuild
index ac6c5c3a8314..ff3a9036301b 100644
--- a/sci-chemistry/avogadro/avogadro-1.1.0.ebuild
+++ b/sci-chemistry/avogadro/avogadro-1.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,17 +15,19 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="+glsl python cpu_flags_x86_sse2 test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
>=sci-chemistry/openbabel-2.3.0
>=dev-qt/qtgui-4.5.3:4
>=dev-qt/qtopengl-4.5.3:4
x11-libs/gl2ps
- glsl? ( >=media-libs/glew-1.5.0 )
+ glsl? ( >=media-libs/glew-1.5.0:0= )
python? (
>=dev-libs/boost-1.35.0-r5[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/sip[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
)"
DEPEND="${RDEPEND}
dev-cpp/eigen:2"
diff --git a/sci-chemistry/avogadro/avogadro-1.1.1.ebuild b/sci-chemistry/avogadro/avogadro-1.1.1.ebuild
index 707931ab0714..5e9225721e1d 100644
--- a/sci-chemistry/avogadro/avogadro-1.1.1.ebuild
+++ b/sci-chemistry/avogadro/avogadro-1.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,17 +15,19 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="+glsl python cpu_flags_x86_sse2 test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
>=sci-chemistry/openbabel-2.3.0
>=dev-qt/qtgui-4.8.5:4
>=dev-qt/qtopengl-4.8.5:4
x11-libs/gl2ps
- glsl? ( >=media-libs/glew-1.5.0 )
+ glsl? ( >=media-libs/glew-1.5.0:0= )
python? (
>=dev-libs/boost-1.35.0-r5[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/sip[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
)"
DEPEND="${RDEPEND}
virtual/pkgconfig