summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-07-24 03:01:55 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-07-24 03:02:20 +0200
commit6195c28a8365c89ad6de6808846d25a1bca0d856 (patch)
tree3181cdf9910fc28f9f6441a12b1c2e2062a22e82
parentmail-client/thunderbird: move fatal rust version check to pkg_setup (diff)
downloadgentoo-6195c28a8365c89ad6de6808846d25a1bca0d856.tar.gz
gentoo-6195c28a8365c89ad6de6808846d25a1bca0d856.tar.bz2
gentoo-6195c28a8365c89ad6de6808846d25a1bca0d856.zip
www-client/firefox: move fatal rust version check to pkg_setup
In case no rust version is installed yet, the rust check in pkg_pretend will block any PM run which would pull in rust. Moving fatal check to pkg_setup will still prevent unnecessary compile time but avoid that block. Bug: https://bugs.gentoo.org/733692 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--www-client/firefox/firefox-68.10.0.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/www-client/firefox/firefox-68.10.0.ebuild b/www-client/firefox/firefox-68.10.0.ebuild
index 9afc1bda5078..15de19c9c31c 100644
--- a/www-client/firefox/firefox-68.10.0.ebuild
+++ b/www-client/firefox/firefox-68.10.0.ebuild
@@ -232,10 +232,10 @@ pkg_pretend() {
local rustc_version=( $(eselect --brief rust show 2>/dev/null) )
rustc_version=${rustc_version[0]/rust-bin-/}
rustc_version=${rustc_version/rust-/}
- [[ -z "${rustc_version}" ]] && die "Failed to determine rustc version!"
-
- if ver_test "${rustc_version}" -ge "1.45.0" ; then
- die "Rust >=1.45.0 is not supported. Please use 'eselect rust' to switch to <rust-1.45.0!"
+ if [[ -n "${rustc_version}" ]] ; then
+ if ver_test "${rustc_version}" -ge "1.45.0" ; then
+ die "Rust >=1.45.0 is not supported. Please use 'eselect rust' to switch to <rust-1.45.0!"
+ fi
fi
if use pgo ; then
@@ -259,6 +259,15 @@ pkg_setup() {
moz_pkgsetup
if [[ ${MERGE_TYPE} != binary ]] ; then
+ local rustc_version=( $(eselect --brief rust show 2>/dev/null) )
+ rustc_version=${rustc_version[0]/rust-bin-/}
+ rustc_version=${rustc_version/rust-/}
+ [[ -z "${rustc_version}" ]] && die "Failed to determine rustc version!"
+
+ if ver_test "${rustc_version}" -ge "1.45.0" ; then
+ die "Rust >=1.45.0 is not supported. Please use 'eselect rust' to switch to <rust-1.45.0!"
+ fi
+
# Ensure we have enough disk space to compile
if use pgo || use lto || use debug || use test ; then
CHECKREQS_DISK_BUILD="8G"