summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-02 21:19:19 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-02 21:28:16 +0200
commit74c9b0b795b1624332c180fa40342ae658f23fd1 (patch)
treed9e8483a87415613df7229e34ab224bb83753b1a
parentgames-strategy/s25rttr: Drop old (diff)
downloadgentoo-74c9b0b795b1624332c180fa40342ae658f23fd1.tar.gz
gentoo-74c9b0b795b1624332c180fa40342ae658f23fd1.tar.bz2
gentoo-74c9b0b795b1624332c180fa40342ae658f23fd1.zip
games-util/dfarc: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--games-util/dfarc/dfarc-3.12-r1.ebuild52
-rw-r--r--games-util/dfarc/files/dfarc-3.12-nowindres.patch4
2 files changed, 54 insertions, 2 deletions
diff --git a/games-util/dfarc/dfarc-3.12-r1.ebuild b/games-util/dfarc/dfarc-3.12-r1.ebuild
new file mode 100644
index 000000000000..c996a7d3172d
--- /dev/null
+++ b/games-util/dfarc/dfarc-3.12-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WX_GTK_VER="3.0"
+inherit eutils gnome2-utils wxwidgets xdg
+
+DESCRIPTION="Frontend and .dmod installer for GNU FreeDink"
+HOMEPAGE="http://www.freedink.org/"
+SRC_URI="mirror://gnu/freedink/${P}.tar.gz"
+
+LICENSE="GPL-3 BZIP2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ app-arch/bzip2
+ x11-misc/xdg-utils
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+"
+DEPEND="${RDEPEND}
+ nls? ( >=dev-util/intltool-0.31 )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-nowindres.patch )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --disable-desktopfiles
+}
+
+src_install() {
+ default
+ dodoc TRANSLATIONS.txt
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}
diff --git a/games-util/dfarc/files/dfarc-3.12-nowindres.patch b/games-util/dfarc/files/dfarc-3.12-nowindres.patch
index 78b71096973c..142658ccb001 100644
--- a/games-util/dfarc/files/dfarc-3.12-nowindres.patch
+++ b/games-util/dfarc/files/dfarc-3.12-nowindres.patch
@@ -1,5 +1,5 @@
---- src/Makefile.in.orig 2016-04-05 12:49:17.997412757 -0400
-+++ src/Makefile.in 2016-04-05 12:50:42.058496766 -0400
+--- a/src/Makefile.in.orig 2016-04-05 12:49:17.997412757 -0400
++++ b/src/Makefile.in 2016-04-05 12:50:42.058496766 -0400
@@ -100,7 +100,6 @@
Package.$(OBJEXT) RecursiveDelete.$(OBJEXT) Tar.$(OBJEXT) \
DFArcFrame_Base.$(OBJEXT) Options_Base.$(OBJEXT) \