summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2018-03-25 01:47:01 -0400
committerPacho Ramos <pacho@gentoo.org>2018-04-14 18:18:27 +0200
commit7e72f270aaaaed1ce09b77b1b5f724bc76d77644 (patch)
treee65b2dda4c8d93692b58a7903c41259b403372da
parentdev-util/codeblocks: Fix building with GCC-7 (diff)
downloadgentoo-7e72f270aaaaed1ce09b77b1b5f724bc76d77644.tar.gz
gentoo-7e72f270aaaaed1ce09b77b1b5f724bc76d77644.tar.bz2
gentoo-7e72f270aaaaed1ce09b77b1b5f724bc76d77644.zip
dev-games/ode: Fix building with GCC-7
Bug: https://bugs.gentoo.org/646538 Package-Manager: Portage-2.3.16, Repoman-2.3.6 Closes: https://bugs.gentoo.org/646538 Closes: https://github.com/gentoo/gentoo/pull/7605
-rw-r--r--dev-games/ode/files/ode-0.14-gcc7.patch52
-rw-r--r--dev-games/ode/ode-0.14-r1.ebuild4
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-games/ode/files/ode-0.14-gcc7.patch b/dev-games/ode/files/ode-0.14-gcc7.patch
new file mode 100644
index 000000000000..aad0117f3bec
--- /dev/null
+++ b/dev-games/ode/files/ode-0.14-gcc7.patch
@@ -0,0 +1,52 @@
+Bug: https://bugs.gentoo.org/646538
+Upstream commit: https://bitbucket.org/odedevs/ode/commits/6f44023660dc830147a56314ea0627a23f11ad86
+
+# HG changeset patch
+# User oleh_derevenko <>
+# Date 1521993135 -10800
+# Node ID 6f44023660dc830147a56314ea0627a23f11ad86
+# Parent 6a68227619feebf85513331d7320b5a89eadf44f
+Fixed: Command line parameter validation errors have been fixed in some demos (reported by Peter Levine)
+
+diff --git a/ode/demo/demo_jointPR.cpp b/ode/demo/demo_jointPR.cpp
+--- a/ode/demo/demo_jointPR.cpp
++++ b/ode/demo/demo_jointPR.cpp
+@@ -328,8 +328,8 @@
+ if (0 == strcmp("-t", argv[i]) || 0 == strcmp("--texture-path", argv[i]))
+ {
+ int j = i+1;
+- if ( j+1 > argc || // Check if we have enough arguments
+- argv[j] == '\0' || // We should have a path here
++ if ( j >= argc || // Check if we have enough arguments
++ argv[j][0] == '\0' || // We should have a path here
+ argv[j][0] == '-' ) // We should have a path not a command line
+ Help(argv);
+ else
+diff --git a/ode/demo/demo_jointPU.cpp b/ode/demo/demo_jointPU.cpp
+--- a/ode/demo/demo_jointPU.cpp
++++ b/ode/demo/demo_jointPU.cpp
+@@ -575,8 +575,8 @@
+
+ if (0 == strcmp ("-t", argv[i]) || 0 == strcmp ("--texture-path", argv[i]) ) {
+ int j = i+1;
+- if ( j+1 > argc || // Check if we have enough arguments
+- argv[j] == '\0' || // We should have a path here
++ if ( j >= argc || // Check if we have enough arguments
++ argv[j][0] == '\0' || // We should have a path here
+ argv[j][0] == '-' ) // We should have a path not a command line
+ Help (argv);
+ else
+diff --git a/ode/demo/demo_piston.cpp b/ode/demo/demo_piston.cpp
+--- a/ode/demo/demo_piston.cpp
++++ b/ode/demo/demo_piston.cpp
+@@ -658,8 +658,8 @@
+ if ( 0 == strcmp ("-t", argv[i]) || 0 == strcmp ("--texture-path", argv[i]) )
+ {
+ int j = i+1;
+- if ( j+1 > argc || // Check if we have enough arguments
+- argv[j] == '\0' || // We should have a path here
++ if ( j >= argc || // Check if we have enough arguments
++ argv[j][0] == '\0' || // We should have a path here
+ argv[j][0] == '-' ) // We should have a path not a command line
+ Help (argv);
+ else
diff --git a/dev-games/ode/ode-0.14-r1.ebuild b/dev-games/ode/ode-0.14-r1.ebuild
index 08bd2181affa..6cb52f0998f7 100644
--- a/dev-games/ode/ode-0.14-r1.ebuild
+++ b/dev-games/ode/ode-0.14-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -22,6 +22,8 @@ DEPEND="${RDEPEND}
MY_EXAMPLES_DIR=/usr/share/doc/${PF}/examples
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.14-gcc7.patch
+
sed -i \
-e "s:\$.*/drawstuff/textures:${MY_EXAMPLES_DIR}:" \
drawstuff/src/Makefile.am \