summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-09 19:30:41 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-09 22:07:32 -0400
commit87649cc62122ef34fca84ecf3ffb10aa571b7bea (patch)
treedc51620b33bd681628e67bcaae97b348e0bef99f
parentapp-misc/tracker: Version bump to 3.3.3 (diff)
downloadgentoo-87649cc62122ef34fca84ecf3ffb10aa571b7bea.tar.gz
gentoo-87649cc62122ef34fca84ecf3ffb10aa571b7bea.tar.bz2
gentoo-87649cc62122ef34fca84ecf3ffb10aa571b7bea.zip
games-board/gnome-chess: Version bump to 42.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--games-board/gnome-chess/Manifest1
-rw-r--r--games-board/gnome-chess/gnome-chess-42.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/games-board/gnome-chess/Manifest b/games-board/gnome-chess/Manifest
index 73f4aa89936a..26040ff4c34a 100644
--- a/games-board/gnome-chess/Manifest
+++ b/games-board/gnome-chess/Manifest
@@ -1 +1,2 @@
DIST gnome-chess-42.0.tar.xz 661180 BLAKE2B e9fe75df1b298aad17b8b199949cb02eeea5116fa15adfedfac6ed067123ff73aad8ebb33e512f1eef97237232275528da6454de27c335a897e5e3b942a335bf SHA512 08af368b6fd032976c124a8fa8402494e73b004591eae331523a377acf72d98b9827ed189db1c1287f758f41614e878062bd1ab0b8323bf76d19b9cdedacf9a6
+DIST gnome-chess-42.1.tar.xz 663036 BLAKE2B 3e42f799d029c4122055420035dd1dadcf5d385ea363ebfe355dc25df31bd5160f2b791d715a2ab371af93e4f5f0a60ac8e818df2686b0f0fc30ae7c0f0795fc SHA512 ab84744910fbf65d50cadb7f63b9e5a5fd4af103adbacd349680c65ae70374ce9766e715656891ae8987ba3c6a694dd632b9154233a417b86a1eeacad875a61d
diff --git a/games-board/gnome-chess/gnome-chess-42.1.ebuild b/games-board/gnome-chess/gnome-chess-42.1.ebuild
new file mode 100644
index 000000000000..a66534404419
--- /dev/null
+++ b/games-board/gnome-chess/gnome-chess-42.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+VALA_MIN_API_VERSION="0.52"
+
+inherit gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Play the classic two-player boardgame of chess"
+HOMEPAGE="https://wiki.gnome.org/Apps/Chess https://gitlab.gnome.org/GNOME/gnome-chess"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ gui-libs/gtk:4
+ >=gui-libs/libadwaita-1.0.0:1
+ >=gnome-base/librsvg-2.46.0:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ gnome-base/librsvg:2[vala]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-util/itstool
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To be able to play against a computer you will need
+to install a chess engine package, for example games-board/gnuchess"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}