summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-04-23 10:14:42 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-04-23 10:14:42 -0500
commit8ff01f78c0fe45cd18dcf9e429be29348589e0c9 (patch)
treeac953d51a10f285727796173426739f2f33078e3
parentdev-python/docker-py: add version 1.8.0-r1 (diff)
downloadgentoo-8ff01f78c0fe45cd18dcf9e429be29348589e0c9.tar.gz
gentoo-8ff01f78c0fe45cd18dcf9e429be29348589e0c9.tar.bz2
gentoo-8ff01f78c0fe45cd18dcf9e429be29348589e0c9.zip
dev-python/docker-py: remove version 1.8.0
Again, due to bug #580388, I am removing this version of docker-py to finish the solution of py2-ipaddress causing collisions. Package-Manager: portage-2.2.28
-rw-r--r--dev-python/docker-py/docker-py-1.8.0.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/docker-py/docker-py-1.8.0.ebuild b/dev-python/docker-py/docker-py-1.8.0.ebuild
deleted file mode 100644
index db7ba70a7d03..000000000000
--- a/dev-python/docker-py/docker-py-1.8.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Python client for Docker"
-HOMEPAGE="https://github.com/docker/docker-py"
-SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( >=dev-python/mkdocs-0.14.0[${PYTHON_USEDEP}] )
- test? (
- ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- ~dev-python/pytest-2.7.2[${PYTHON_USEDEP}]
- ~dev-python/pytest-cov-2.1.0[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/py2-ipaddress-3.4.1[${PYTHON_USEDEP}]' 'python2_7')
-"
-
-python_compile_all() {
- if use doc; then
- mkdocs build -d 'mkdocs_site' || die "docs failed to build"
- fi
-}
-
-python_test() {
- py.test tests/unit/ | die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( mkdocs_site/. )
-
- distutils-r1_python_install_all
-}