summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-08-28 18:21:45 -0400
committerMike Gilbert <floppym@gentoo.org>2017-09-02 21:14:43 -0400
commit934192b55ae7ecc82be37fad7b9060e2bd1abd3d (patch)
treea0b7752fe2dedb7d396c923444052fda4062de60
parentsystemd.eclass: add systemd_reenable function (diff)
downloadgentoo-934192b55ae7ecc82be37fad7b9060e2bd1abd3d.tar.gz
gentoo-934192b55ae7ecc82be37fad7b9060e2bd1abd3d.tar.bz2
gentoo-934192b55ae7ecc82be37fad7b9060e2bd1abd3d.zip
x11-misc/sddm: call systemd_reenable in postinst
Bug: https://bugs.gentoo.org/627984 Package-Manager: Portage-2.3.6_p39, Repoman-2.3.3_p17
-rw-r--r--x11-misc/sddm/sddm-0.14.0-r2.ebuild4
-rw-r--r--x11-misc/sddm/sddm-0.14.0-r4.ebuild4
-rw-r--r--x11-misc/sddm/sddm-0.15.0.ebuild4
3 files changed, 9 insertions, 3 deletions
diff --git a/x11-misc/sddm/sddm-0.14.0-r2.ebuild b/x11-misc/sddm/sddm-0.14.0-r2.ebuild
index 8946151552d6..f3ac6dba4c95 100644
--- a/x11-misc/sddm/sddm-0.14.0-r2.ebuild
+++ b/x11-misc/sddm/sddm-0.14.0-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-utils user
+inherit cmake-utils systemd user
DESCRIPTION="Simple Desktop Display Manager"
HOMEPAGE="https://github.com/sddm/sddm"
@@ -68,6 +68,8 @@ pkg_postinst() {
enewgroup ${PN}
enewuser ${PN} -1 -1 /var/lib/${PN} ${PN},video
+ systemd_reenable sddm.service
+
if use consolekit && use pam && [[ -e "${ROOT}"/etc/pam.d/system-login ]]; then
local line=$(grep "pam_ck_connector.*nox11" "${ROOT}"/etc/pam.d/system-login)
if [[ -z ${line} ]]; then
diff --git a/x11-misc/sddm/sddm-0.14.0-r4.ebuild b/x11-misc/sddm/sddm-0.14.0-r4.ebuild
index a79ea8f1a2f8..f67abdc0bdcf 100644
--- a/x11-misc/sddm/sddm-0.14.0-r4.ebuild
+++ b/x11-misc/sddm/sddm-0.14.0-r4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-utils user
+inherit cmake-utils systemd user
DESCRIPTION="Simple Desktop Display Manager"
HOMEPAGE="https://github.com/sddm/sddm"
@@ -74,6 +74,8 @@ pkg_postinst() {
enewgroup ${PN}
enewuser ${PN} -1 -1 /var/lib/${PN} ${PN},video
+ systemd_reenable sddm.service
+
if use consolekit && use pam && [[ -e "${ROOT}"/etc/pam.d/system-login ]]; then
local line=$(grep "pam_ck_connector.*nox11" "${ROOT}"/etc/pam.d/system-login)
if [[ -z ${line} ]]; then
diff --git a/x11-misc/sddm/sddm-0.15.0.ebuild b/x11-misc/sddm/sddm-0.15.0.ebuild
index 0099ac086cd7..acd5a8fc7556 100644
--- a/x11-misc/sddm/sddm-0.15.0.ebuild
+++ b/x11-misc/sddm/sddm-0.15.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils user
+inherit cmake-utils systemd user
DESCRIPTION="Simple Desktop Display Manager"
HOMEPAGE="https://github.com/sddm/sddm"
@@ -59,4 +59,6 @@ src_configure() {
pkg_postinst() {
enewgroup ${PN}
enewuser ${PN} -1 -1 /var/lib/${PN} ${PN},video
+
+ systemd_reenable sddm.service
}