summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-02-28 09:52:42 -0600
committerMatthias Maier <tamiko@gentoo.org>2016-02-28 09:58:08 -0600
commit93a409d4eb7f22d1bc4644b02a93af2bf3c017b0 (patch)
treebf7ae96a1ebb147c44f41d8450c6e391f59e0af4
parenteclass/gnome2.eclass: add bug reference about the need of running elibtoolize (diff)
downloadgentoo-93a409d4eb7f22d1bc4644b02a93af2bf3c017b0.tar.gz
gentoo-93a409d4eb7f22d1bc4644b02a93af2bf3c017b0.tar.bz2
gentoo-93a409d4eb7f22d1bc4644b02a93af2bf3c017b0.zip
app-doc/doxygen: Avoid a sandbox violation with (bug #564944)
Export VARTEXFONTS="${T}/fonts" such that kpathsea does not try to write to /var/cache/fonts/pk/... during doc generation. Package-Manager: portage-2.2.26
-rw-r--r--app-doc/doxygen/doxygen-1.8.10-r1.ebuild6
-rw-r--r--app-doc/doxygen/doxygen-1.8.11.ebuild6
-rw-r--r--app-doc/doxygen/doxygen-9999.ebuild6
3 files changed, 12 insertions, 6 deletions
diff --git a/app-doc/doxygen/doxygen-1.8.10-r1.ebuild b/app-doc/doxygen/doxygen-1.8.10-r1.ebuild
index 86e2e326d463..17b7a1c66800 100644
--- a/app-doc/doxygen/doxygen-1.8.10-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.8.10-r1.ebuild
@@ -139,9 +139,11 @@ src_compile() {
cmake-utils_src_compile
# generate html and pdf documents. errors here are not considered
- # fatal, hence the ewarn message TeX's font caching in /var/cache/fonts
- # causes sandbox warnings, so we allow it.
+ # fatal, hence the ewarn message.
+
if use doc; then
+ export VARTEXFONTS="${T}/fonts" # bug #564944
+
if ! use dot; then
sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
{Doxyfile,doc/Doxyfile} \
diff --git a/app-doc/doxygen/doxygen-1.8.11.ebuild b/app-doc/doxygen/doxygen-1.8.11.ebuild
index fefba30fbd09..cdc0d9ab9dd5 100644
--- a/app-doc/doxygen/doxygen-1.8.11.ebuild
+++ b/app-doc/doxygen/doxygen-1.8.11.ebuild
@@ -141,9 +141,11 @@ src_compile() {
cmake-utils_src_compile
# generate html and pdf documents. errors here are not considered
- # fatal, hence the ewarn message TeX's font caching in /var/cache/fonts
- # causes sandbox warnings, so we allow it.
+ # fatal, hence the ewarn message.
+
if use doc; then
+ export VARTEXFONTS="${T}/fonts" # bug #564944
+
if ! use dot; then
sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
{Doxyfile,doc/Doxyfile} \
diff --git a/app-doc/doxygen/doxygen-9999.ebuild b/app-doc/doxygen/doxygen-9999.ebuild
index 6be87bcb1ac5..24343d46489f 100644
--- a/app-doc/doxygen/doxygen-9999.ebuild
+++ b/app-doc/doxygen/doxygen-9999.ebuild
@@ -140,9 +140,11 @@ src_compile() {
cmake-utils_src_compile
# generate html and pdf documents. errors here are not considered
- # fatal, hence the ewarn message TeX's font caching in /var/cache/fonts
- # causes sandbox warnings, so we allow it.
+ # fatal, hence the ewarn message.
+
if use doc; then
+ export VARTEXFONTS="${T}/fonts" # bug #564944
+
if ! use dot; then
sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
{Doxyfile,doc/Doxyfile} \