summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-doc/doxygen/doxygen-1.8.10-r1.ebuild6
-rw-r--r--app-doc/doxygen/doxygen-1.8.11.ebuild6
-rw-r--r--app-doc/doxygen/doxygen-9999.ebuild6
3 files changed, 12 insertions, 6 deletions
diff --git a/app-doc/doxygen/doxygen-1.8.10-r1.ebuild b/app-doc/doxygen/doxygen-1.8.10-r1.ebuild
index 86e2e326d463..17b7a1c66800 100644
--- a/app-doc/doxygen/doxygen-1.8.10-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.8.10-r1.ebuild
@@ -139,9 +139,11 @@ src_compile() {
cmake-utils_src_compile
# generate html and pdf documents. errors here are not considered
- # fatal, hence the ewarn message TeX's font caching in /var/cache/fonts
- # causes sandbox warnings, so we allow it.
+ # fatal, hence the ewarn message.
+
if use doc; then
+ export VARTEXFONTS="${T}/fonts" # bug #564944
+
if ! use dot; then
sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
{Doxyfile,doc/Doxyfile} \
diff --git a/app-doc/doxygen/doxygen-1.8.11.ebuild b/app-doc/doxygen/doxygen-1.8.11.ebuild
index fefba30fbd09..cdc0d9ab9dd5 100644
--- a/app-doc/doxygen/doxygen-1.8.11.ebuild
+++ b/app-doc/doxygen/doxygen-1.8.11.ebuild
@@ -141,9 +141,11 @@ src_compile() {
cmake-utils_src_compile
# generate html and pdf documents. errors here are not considered
- # fatal, hence the ewarn message TeX's font caching in /var/cache/fonts
- # causes sandbox warnings, so we allow it.
+ # fatal, hence the ewarn message.
+
if use doc; then
+ export VARTEXFONTS="${T}/fonts" # bug #564944
+
if ! use dot; then
sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
{Doxyfile,doc/Doxyfile} \
diff --git a/app-doc/doxygen/doxygen-9999.ebuild b/app-doc/doxygen/doxygen-9999.ebuild
index 6be87bcb1ac5..24343d46489f 100644
--- a/app-doc/doxygen/doxygen-9999.ebuild
+++ b/app-doc/doxygen/doxygen-9999.ebuild
@@ -140,9 +140,11 @@ src_compile() {
cmake-utils_src_compile
# generate html and pdf documents. errors here are not considered
- # fatal, hence the ewarn message TeX's font caching in /var/cache/fonts
- # causes sandbox warnings, so we allow it.
+ # fatal, hence the ewarn message.
+
if use doc; then
+ export VARTEXFONTS="${T}/fonts" # bug #564944
+
if ! use dot; then
sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
{Doxyfile,doc/Doxyfile} \