summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-20 16:54:26 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-21 09:18:29 +0200
commita472ac3e8e8180995d67b099a26a44eb5200b9cb (patch)
treec638f08435ed2793a8e3464b879d8b3ee3a025b4
parentdev-python/certifi: Fork the patch into certifi-shim (diff)
downloadgentoo-a472ac3e8e8180995d67b099a26a44eb5200b9cb.tar.gz
gentoo-a472ac3e8e8180995d67b099a26a44eb5200b9cb.tar.bz2
gentoo-a472ac3e8e8180995d67b099a26a44eb5200b9cb.zip
www-client/chromium: Silence some GCC warnings
Silence some warnings specific to GCC that keep appearing for a very long time. Since upstream does not care about GCC, they are unlikely to ever disappear. Since they often affect header files, they repeat often and unnecessarily increase build log size. Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/16343 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--www-client/chromium/chromium-84.0.4147.45-r1.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-84.0.4147.45-r1.ebuild b/www-client/chromium/chromium-84.0.4147.45-r1.ebuild
index baebfbedc074..966c8a05a06d 100644
--- a/www-client/chromium/chromium-84.0.4147.45-r1.ebuild
+++ b/www-client/chromium/chromium-84.0.4147.45-r1.ebuild
@@ -658,6 +658,9 @@ src_configure() {
# Chromium relies on this, but was disabled in >=clang-10, crbug.com/1042470
append-cxxflags $(test-flags-CXX -flax-vector-conversions=all)
+ # Silence lots of GCC warnings upstream doesn't seem to care about
+ append-cxxflags -Wno-invalid-offsetof -Wno-attributes -Wno-pragmas
+
# Explicitly disable ICU data file support for system-icu builds.
if use system-icu; then
myconf_gn+=" icu_use_data_file=false"