summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-04-14 18:18:15 +0200
committerJohannes Huber <johu@gentoo.org>2018-04-14 18:20:02 +0200
commitb7678bfd37e7325c2ddce8a69605760b780527b0 (patch)
tree80372d7e6ac8c3845cda7acd3903b41ed44d4052
parentdev-games/ode: Fix building with GCC-7 (diff)
downloadgentoo-b7678bfd37e7325c2ddce8a69605760b780527b0.tar.gz
gentoo-b7678bfd37e7325c2ddce8a69605760b780527b0.tar.bz2
gentoo-b7678bfd37e7325c2ddce8a69605760b780527b0.zip
media-sound/elisa: New package
Import from kde overlay. Initial ebuild by me. Various improvements by Andreas Sturmlechner and me. Have fun while listening to music. Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--media-sound/elisa/Manifest1
-rw-r--r--media-sound/elisa/elisa-0.1.ebuild61
-rw-r--r--media-sound/elisa/metadata.xml11
3 files changed, 73 insertions, 0 deletions
diff --git a/media-sound/elisa/Manifest b/media-sound/elisa/Manifest
new file mode 100644
index 000000000000..bd0a66514e74
--- /dev/null
+++ b/media-sound/elisa/Manifest
@@ -0,0 +1 @@
+DIST elisa-0.1.tar.xz 1461076 BLAKE2B 7b4bd7e32681d3bda30b27110f9610f8fb9435e7f60ba62899b743bd79414188d62f1b8cd229a073025bcc7de9b7ec4c0750b7bdde8845dbb088b7a6a245bf99 SHA512 3f8bfa08a7183843ce3aeecae96c3f5eed73693a8d6cbce24cd83de3ca47475b4549af5e68b7e2b4c2d281faffe9bee1675f749913b44a4742c28ad1a4efd7c9
diff --git a/media-sound/elisa/elisa-0.1.ebuild b/media-sound/elisa/elisa-0.1.ebuild
new file mode 100644
index 000000000000..59f7d8a72c82
--- /dev/null
+++ b/media-sound/elisa/elisa-0.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+KDE_HANDBOOK="optional"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Simple music player by KDE"
+HOMEPAGE="https://community.kde.org/Elisa"
+LICENSE="LGPL-3+"
+IUSE="mpris semantic-desktop"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtmultimedia 'gstreamer')
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtwidgets)
+ mpris? (
+ $(add_frameworks_dep kdbusaddons)
+ $(add_qt_dep qtdbus)
+ )
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_qt_dep qtgraphicaleffects)
+ $(add_qt_dep qtquickcontrols)
+ $(add_qt_dep qtquickcontrols2)
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package mpris KF5DBusAddons)
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ )
+
+ kde5_src_configure
+}
diff --git a/media-sound/elisa/metadata.xml b/media-sound/elisa/metadata.xml
new file mode 100644
index 000000000000..22e16aa35e94
--- /dev/null
+++ b/media-sound/elisa/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <use>
+ <flag name="mpris">Enable MPRIS support</flag>
+ </use>
+</pkgmetadata>