summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-27 11:09:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-27 11:26:01 +0200
commitd4333a4c699b3861c954b0de7d4a5509b677540b (patch)
treed3146e4dc516cafa3fee36c40db4c771cc184184
parentdev-ros/fake_localization: Bump to 1.16.0. (diff)
downloadgentoo-d4333a4c699b3861c954b0de7d4a5509b677540b.tar.gz
gentoo-d4333a4c699b3861c954b0de7d4a5509b677540b.tar.bz2
gentoo-d4333a4c699b3861c954b0de7d4a5509b677540b.zip
dev-ros/global_planner: Bump to 1.16.0.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--dev-ros/global_planner/Manifest1
-rw-r--r--dev-ros/global_planner/global_planner-1.16.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/global_planner/Manifest b/dev-ros/global_planner/Manifest
index 1130f354eeda..edf0b0147ba3 100644
--- a/dev-ros/global_planner/Manifest
+++ b/dev-ros/global_planner/Manifest
@@ -1,2 +1,3 @@
DIST navigation-1.15.1.tar.gz 346480 BLAKE2B 29f9a0b6f2c62bd21a7cb87a64b490c845bb7db4af338fd094744abb22402df7eedc8c164b64f93f2d67dabaff99ca3b946b45e93173bed74834d9e3668726ad SHA512 25c5093bf7acca9d15d46bb2d0ae7e4ce0fa45f18b32d1626668dcbd33732317e8535b978e7225d86391472c517f05acb7736f31a7c511c8736ab8a22c7af4b0
DIST navigation-1.15.2.tar.gz 348985 BLAKE2B 866779425828b1e4c3a044654ae41f33643646ca70cf6841f23bce265add2c420bf0934a41a6b29fa65fc421228a31dc15e9fb0f6cc4295ce12adbbb627b43d4 SHA512 582422756b31b4d83e929e3c723e7205e772b9775fcf618c9bd5d3c54af1f20e9bc8a0143626750c0c3cffeb0cbea8f8706b7e66f62dc037cfe12b05f23ee142
+DIST navigation-1.16.0.tar.gz 336708 BLAKE2B 74fdc7c3afb00bfbded011678c90b22cc95fe45b126c9a8a4bb9a80f8676ed0ade32e02ad77ec643f167d9719e71347750b6f7993f61cf743fc018d1412436d6 SHA512 ee6336627c2e095ef089534c19b7258f394858a6c04ad49b3aa6e1d0acca67c245c2743f04752be137864dba216c3aa38e34c3e40e3db7839308be3adbc808d6
diff --git a/dev-ros/global_planner/global_planner-1.16.0.ebuild b/dev-ros/global_planner/global_planner-1.16.0.ebuild
new file mode 100644
index 000000000000..309d248922f0
--- /dev/null
+++ b/dev-ros/global_planner/global_planner-1.16.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Path planner library and node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/navfn
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+
+ dev-ros/angles
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"