summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-07 10:54:57 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-07 10:54:57 -0700
commitd711716379d428cb654dfac9d75d4341bead563e (patch)
treebc115e9c614a7279b34738098c17686f43db1637
parentdev-python/retry-decorator-1.1.1: bump, add py38, enable tests (diff)
downloadgentoo-d711716379d428cb654dfac9d75d4341bead563e.tar.gz
gentoo-d711716379d428cb654dfac9d75d4341bead563e.tar.bz2
gentoo-d711716379d428cb654dfac9d75d4341bead563e.zip
dev-python/pyu2f-0.1.4-r1: revbump, EAPI=7, py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/pyu2f/pyu2f-0.1.4-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyu2f/pyu2f-0.1.4-r1.ebuild b/dev-python/pyu2f/pyu2f-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..dec1edfe2792
--- /dev/null
+++ b/dev-python/pyu2f/pyu2f-0.1.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python based U2F host library"
+HOMEPAGE="https://github.com/google/pyu2f"
+SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e 's:json.loads(communicate_json):json.loads(communicate_json.decode()):' \
+ -i pyu2f/tests/customauthenticator_test.py || die
+
+ distutils-r1_python_prepare_all
+}