summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert <jchelmertt3@gmail.com>2019-10-05 20:12:35 -0500
committerConrad Kostecki <conikost@gentoo.org>2019-12-11 22:01:23 +0100
commitd94d9c7a0ae2aaa3120ada7ccc0578c68d0a1e53 (patch)
tree9f763f399a14a00bd6baeba398ecb29916a8b3f2
parentdev-lang/crystal: bump up to 0.32.0 (diff)
downloadgentoo-d94d9c7a0ae2aaa3120ada7ccc0578c68d0a1e53.tar.gz
gentoo-d94d9c7a0ae2aaa3120ada7ccc0578c68d0a1e53.tar.bz2
gentoo-d94d9c7a0ae2aaa3120ada7ccc0578c68d0a1e53.zip
media-sound/pulsemixer: New package
CLI and curses mixer for Pulseaudio Closes: https://github.com/gentoo/gentoo/pull/13180 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: John Helmert III <jchelmertt3@gmail.com> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--media-sound/pulsemixer/Manifest1
-rw-r--r--media-sound/pulsemixer/metadata.xml16
-rw-r--r--media-sound/pulsemixer/pulsemixer-1.5.0.ebuild25
-rw-r--r--media-sound/pulsemixer/pulsemixer-9999.ebuild25
4 files changed, 67 insertions, 0 deletions
diff --git a/media-sound/pulsemixer/Manifest b/media-sound/pulsemixer/Manifest
new file mode 100644
index 000000000000..5317857c3f8f
--- /dev/null
+++ b/media-sound/pulsemixer/Manifest
@@ -0,0 +1 @@
+DIST pulsemixer-1.5.0.tar.gz 21557 BLAKE2B 4c6cb9a3f9701301223c259532a0803a5c3e5f3abbce6f2763b6fd987f85aba56549e66861e9b69d0bf89c116c6c7e221d11cc65eb9a531402f74e8d63e9d824 SHA512 e07556a0cf2c9f660764977158cf1e338f7d8a92eae639c4a8f355847840e3aa9fb65adf553dbde905b64f2eff57c630bbfe19cfd5420b6205b1e2f688a6de64
diff --git a/media-sound/pulsemixer/metadata.xml b/media-sound/pulsemixer/metadata.xml
new file mode 100644
index 000000000000..8878000e28fb
--- /dev/null
+++ b/media-sound/pulsemixer/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jchelmertt3@gmail.com</email>
+ <name>John Helmert III</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">GeorgeFilipkin/pulsemixer</remote-id>
+ <changelog>https://github.com/GeorgeFilipkin/pulsemixer/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/pulsemixer/pulsemixer-1.5.0.ebuild b/media-sound/pulsemixer/pulsemixer-1.5.0.ebuild
new file mode 100644
index 000000000000..45f1ee6b0c9b
--- /dev/null
+++ b/media-sound/pulsemixer/pulsemixer-1.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="CLI and curses mixer for PulseAudio"
+HOMEPAGE="https://github.com/GeorgeFilipkin/pulsemixer"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/GeorgeFilipkin/${PN}"
+else
+ SRC_URI="https://github.com/GeorgeFilipkin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="media-sound/pulseaudio"
diff --git a/media-sound/pulsemixer/pulsemixer-9999.ebuild b/media-sound/pulsemixer/pulsemixer-9999.ebuild
new file mode 100644
index 000000000000..45f1ee6b0c9b
--- /dev/null
+++ b/media-sound/pulsemixer/pulsemixer-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="CLI and curses mixer for PulseAudio"
+HOMEPAGE="https://github.com/GeorgeFilipkin/pulsemixer"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/GeorgeFilipkin/${PN}"
+else
+ SRC_URI="https://github.com/GeorgeFilipkin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="media-sound/pulseaudio"