summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-10 04:29:52 +0100
committerSam James <sam@gentoo.org>2022-08-10 04:30:54 +0100
commitef3d28b9ec4691891312c63b9e411d024b1c00ac (patch)
tree3e02020d6ff544bfcf157c8665fc9c62be88777f
parentgames-board/gnome-chess: Version bump to 42.1 (diff)
downloadgentoo-ef3d28b9ec4691891312c63b9e411d024b1c00ac.tar.gz
gentoo-ef3d28b9ec4691891312c63b9e411d024b1c00ac.tar.bz2
gentoo-ef3d28b9ec4691891312c63b9e411d024b1c00ac.zip
sys-cluster/crmsh: switch to python-single-r1
It doesn't support multiple Python implementations right now but it wasn't using python-r1 correctly anyway (missing python_setup) and was ignoring the selected target, just going off /usr/bin/python3. Closes: https://bugs.gentoo.org/864430 Closes: https://bugs.gentoo.org/863749 Closes: https://bugs.gentoo.org/728152 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-cluster/crmsh/crmsh-4.2.1-r3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-cluster/crmsh/crmsh-4.2.1-r3.ebuild b/sys-cluster/crmsh/crmsh-4.2.1-r3.ebuild
new file mode 100644
index 000000000000..88ea25ce1490
--- /dev/null
+++ b/sys-cluster/crmsh/crmsh-4.2.1-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/crmsh/crmsh"
+ inherit git-r3
+ S="${WORKDIR}/${PN}-${MY_TREE}"
+else
+ SRC_URI="https://github.com/crmsh/crmsh/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~hppa ~x86"
+fi
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Pacemaker command line interface for management and configuration"
+HOMEPAGE="https://crmsh.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=sys-cluster/pacemaker-1.1.9"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/parallax[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ python_optimize
+}