summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 16:46:06 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:53:40 +0100
commitf7c4d60fef6b645d1ffdccb5c6e1c0f1cfe44f71 (patch)
treefafd5dc29444d5c947548ed06d865607e3325500
parentmedia-libs/sdl-gfx: drop no-op USE=static-libs (diff)
downloadgentoo-f7c4d60fef6b645d1ffdccb5c6e1c0f1cfe44f71.tar.gz
gentoo-f7c4d60fef6b645d1ffdccb5c6e1c0f1cfe44f71.tar.bz2
gentoo-f7c4d60fef6b645d1ffdccb5c6e1c0f1cfe44f71.zip
media-libs/sdl2-gfx: drop no-op USE=static-libs
We add --disable-static just to be sure though. We were already unconditionally deleting both .la and .a, so the USE flag did nothing. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild b/media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild
index 494a39f77f5a..7208220ba2c4 100644
--- a/media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild
+++ b/media-libs/sdl2-gfx/sdl2-gfx-1.0.4.ebuild
@@ -2,27 +2,27 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit autotools multilib-minimal
MY_P="${P/sdl2-/SDL2_}"
DESCRIPTION="Graphics drawing primitives library for SDL2"
HOMEPAGE="http://www.ferzkopp.net/joomla/content/view/19/14/"
SRC_URI="http://www.ferzkopp.net/Software/SDL2_gfx/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="amd64 ~ppc64 x86"
-IUSE="doc cpu_flags_x86_mmx static-libs"
+IUSE="doc cpu_flags_x86_mmx"
DEPEND=">=media-libs/libsdl2-2.0.1-r1[video,${MULTILIB_USEDEP}]"
RDEPEND="${DEPEND}"
DOCS=( AUTHORS ChangeLog README )
-S=${WORKDIR}/${MY_P}
-
PATCHES=(
- "${FILESDIR}/${PN}-1.0.4-slibtool.patch"
+ "${FILESDIR}"/${PN}-1.0.4-slibtool.patch
)
src_prepare() {
@@ -37,16 +37,19 @@ src_prepare() {
multilib_src_configure() {
local myeconfargs=(
$(use_enable cpu_flags_x86_mmx mmx)
- $(use_enable static-libs static)
+ --disable-static
)
+
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
einstalldocs
+
if use doc ; then
docinto html
dodoc -r Docs/html/*
fi
+
find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
}