summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/at-spi2-atk/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/at-spi2-atk/files')
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h36
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch26
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch55
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-accessible.xml16
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-action.xml11
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-component.xml13
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test.xml16
7 files changed, 173 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h
new file mode 100644
index 000000000000..17aefcdd03d7
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h
@@ -0,0 +1,36 @@
+/*
+ * AT-SPI - Assistive Technology Service Provider Interface
+ * (Gnome Accessibility Project; https://wiki.gnome.org/Accessibility)
+ *
+ * Copyright (c) 2014 Samsung Electronics Co., Ltd.
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Library General Public
+ * License as published by the Free Software Foundation; either
+ * version 2 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Library General Public License for more details.
+ *
+ * You should have received a copy of the GNU Library General Public
+ * License along with this library; if not, write to the
+ * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+ * Boston, MA 02111-1307, USA.
+ */
+
+#ifndef _ATK_SUITE_H
+#define _ATK_SUITE_H
+
+#include <atspi/atspi.h>
+
+#define ATK_TEST_PATH_ACCESSIBLE (const char *)"/Accessible"
+#define ATK_TEST_PATH_ACTION (const char *)"/Action"
+#define ATK_TEST_PATH_COMP (const char *)"/Component"
+
+void atk_test_accessible (void);
+void atk_test_action (void);
+void atk_test_component (void);
+
+#endif /* _ATK_SUITE_H */
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch
new file mode 100644
index 000000000000..a8f02a0eae1f
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch
@@ -0,0 +1,26 @@
+From 72220192a31df6b297312d82f059e9824e8a4dc3 Mon Sep 17 00:00:00 2001
+From: Christian Hergert <christian@hergert.me>
+Date: Fri, 15 May 2015 13:07:18 -0700
+Subject: [PATCH] atk-adapter: be careful with potential NULL GObjects
+
+I've been seeing warnings in my Gtk application for a while due to this.
+---
+ atk-adaptor/accessible-stateset.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/atk-adaptor/accessible-stateset.c b/atk-adaptor/accessible-stateset.c
+index f82910b..82820de 100644
+--- a/atk-adaptor/accessible-stateset.c
++++ b/atk-adaptor/accessible-stateset.c
+@@ -185,7 +185,7 @@ spi_atk_state_to_dbus_array (AtkObject * object, dbus_uint32_t * array)
+ {
+ AtkStateSet *set = atk_object_ref_state_set (object);
+ spi_atk_state_set_to_dbus_array (set, array);
+- g_object_unref (set);
++ g_clear_object (&set);
+ }
+
+ void
+--
+2.4.3
+
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch
new file mode 100644
index 000000000000..df9f006350d4
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch
@@ -0,0 +1,55 @@
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 6d388c9..b05b9bd 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -9,15 +9,15 @@ atk_test_CFLAGS = $(DBUS_CFLAGS) \
+ $(ATSPI_CFLAGS) \
+ -I$(top_builddir)\
+ -I$(top_srcdir)/tests/dummyatk/ \
+- -I$(top_srcdir)/tests/dummyatk/.libs \
+- -I$(top_srcdir)/tests/dummyatk/.deps \
++ -I$(top_builddir)/tests/dummyatk/.libs \
++ -I$(top_builddir)/tests/dummyatk/.deps \
+ -I$(top_srcdir)
+
+-atk_test_LDFLAGS = libxmlloader.la \
+- libtestutils.la \
+- $(GLIB_LIBS) \
+- $(ATSPI_LIBS) \
+- $(top_srcdir)/tests/dummyatk/libdummyatk.la
++atk_test_LDADD = libxmlloader.la \
++ libtestutils.la \
++ $(GLIB_LIBS) \
++ $(ATSPI_LIBS) \
++ $(top_builddir)/tests/dummyatk/libdummyatk.la
+
+ atk_test_CPPFLAGS = -DTESTS_BUILD_DIR=\"$(top_builddir)/tests\" \
+ -DTESTS_SRC_DIR=\"$(top_srcdir)/tests\" \
+@@ -34,12 +34,12 @@ app_test_CFLAGS = -I$(top_builddir) \
+ -I$(top_srcdir)/tests/dummyatk \
+ -I$(top_srcdir)/atk-adaptor
+
+-app_test_LDFLAGS = libxmlloader.la \
+- libtestutils.la \
+- $(GLIB_LIBS) \
+- $(ATK_LIBS) \
+- $(top_srcdir)/tests/dummyatk/libdummyatk.la \
+- $(top_srcdir)/atk-adaptor/libatk-bridge-2.0.la
++app_test_LDADD = libxmlloader.la \
++ libtestutils.la \
++ $(GLIB_LIBS) \
++ $(ATK_LIBS) \
++ $(top_builddir)/tests/dummyatk/libdummyatk.la \
++ $(top_builddir)/atk-adaptor/libatk-bridge-2.0.la
+
+ app_test_SOURCES = test-application.c
+
+@@ -52,7 +52,7 @@ libxmlloader_la_CFLAGS = $(GLIB_CFLAGS) \
+ libxmlloader_la_LIBADD = $(GLIB_LIBS) \
+ $(XML_LIBS) \
+ $(GOBJ_LIBS) \
+- $(top_srcdir)/tests/dummyatk/libdummyatk.la \
++ $(top_builddir)/tests/dummyatk/libdummyatk.la \
+ $(ATK_LIBS)
+
+ libxmlloader_la_SOURCES = atk-object-xml-loader.c\
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-accessible.xml b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-accessible.xml
new file mode 100644
index 000000000000..26728ddfd6f2
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-accessible.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" ?>
+<accessible description="Root of the accessible tree" name="root_object" role="accelerator label">
+ <accessible description="first child" name="obj1" role="alert">
+ <state state_enum="modal"/>
+ <state state_enum="multi-line"/>
+ </accessible>
+ <accessible description="second child" name="obj2" role="animation">
+ <accessible description="first prechild" name="obj2/1" role="arrow">
+ <relation relation_type="2" target_name="obj2"/>
+ </accessible>
+ <accessible description="second prechild" name="obj2/2" role="canvas"/>
+ </accessible>
+ <accessible description="third child" name="obj3" role="check box">
+ <accessible description="first prechild" name="obj3/1" role="check menu item"/>
+ </accessible>
+</accessible>
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-action.xml b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-action.xml
new file mode 100644
index 000000000000..41ddf00760e3
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-action.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" ?>
+<accessible description="Root of the accessible tree" name="root_object" role="accelerator label">
+ <accessible description="first child" name="obj1" role="alert"/>
+ <accessible_action description="second child" name="obj2" role="application">
+ <action action_name="action1" action_description="action1 description" key_binding="action1 key binding"/>
+ <action action_name="action2" action_description="action2 description" key_binding="action2 key binding"/>
+ </accessible_action>
+ <accessible_action description="third child" name="obj3" role="push button">
+ <action action_name="action1" action_description="action1 description" key_binding="action1 key binding"/>
+ </accessible_action>
+</accessible>
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-component.xml b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-component.xml
new file mode 100644
index 000000000000..80929b0cf7a0
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-component.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" ?>
+<accessible description="Root of the accessible tree" name="root_object" role="accelerator label">
+ <accessible_component description="second child" name="obj2" role="application">
+ <component x="350" y="200" width="0" height="0" layer="2" zorder="1" alpha="1.5"/>
+ </accessible_component>
+ <accessible_component description="third child" name="obj3" role="push button">
+ <component x="250" y="250" width="350" height="200" layer="3" zorder="2" alpha="2.5"/>
+ <accessible_component description="third child a" name="aobj3" role="push button">
+ <component x="250" y="250" width="350" height="200" layer="4" zorder="3" alpha="3.5"/>
+ </accessible_component>
+ </accessible_component>
+ <accessible description="second child" name="obj2" role="application" />
+</accessible>
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test.xml b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test.xml
new file mode 100644
index 000000000000..26728ddfd6f2
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" ?>
+<accessible description="Root of the accessible tree" name="root_object" role="accelerator label">
+ <accessible description="first child" name="obj1" role="alert">
+ <state state_enum="modal"/>
+ <state state_enum="multi-line"/>
+ </accessible>
+ <accessible description="second child" name="obj2" role="animation">
+ <accessible description="first prechild" name="obj2/1" role="arrow">
+ <relation relation_type="2" target_name="obj2"/>
+ </accessible>
+ <accessible description="second prechild" name="obj2/2" role="canvas"/>
+ </accessible>
+ <accessible description="third child" name="obj3" role="check box">
+ <accessible description="first prechild" name="obj3/1" role="check menu item"/>
+ </accessible>
+</accessible>