summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/pocketsphinx/pocketsphinx-0.8.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/pocketsphinx/pocketsphinx-0.8.ebuild')
-rw-r--r--app-accessibility/pocketsphinx/pocketsphinx-0.8.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-accessibility/pocketsphinx/pocketsphinx-0.8.ebuild b/app-accessibility/pocketsphinx/pocketsphinx-0.8.ebuild
new file mode 100644
index 000000000000..a3c70ee40a98
--- /dev/null
+++ b/app-accessibility/pocketsphinx/pocketsphinx-0.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+inherit eutils distutils-r1
+
+DESCRIPTION="Large open source vocabulary, speaker-independent continuous speech recognition engine"
+HOMEPAGE="https://sourceforge.net/projects/cmusphinx/"
+SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="python static-libs"
+
+RDEPEND="app-accessibility/sphinxbase
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+run_distutils() {
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_"${@}"
+ popd > /dev/null || die
+ fi
+}
+
+src_configure() {
+ econf \
+ --without-python \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ run_distutils ${FUNCNAME}
+}
+
+src_install() {
+ default
+ run_distutils ${FUNCNAME}
+ prune_libtool_files
+}