summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Trotsenko <oleksandr.trotsenko@gmail.com>2018-05-05 09:16:15 -0500
committerPatrice Clement <monsieurp@gentoo.org>2018-05-06 23:48:10 +0200
commit36b65c0cc3a13b57c1236c787bc290d2f229d43d (patch)
treebb1d469b160af0a6187ec3fccd1771b5287ff545 /app-admin/apachetop/apachetop-0.18.4.ebuild
parentsci-libs/hdf: amd64 stable wrt bug #630868 (diff)
downloadgentoo-36b65c0cc3a13b57c1236c787bc290d2f229d43d.tar.gz
gentoo-36b65c0cc3a13b57c1236c787bc290d2f229d43d.tar.bz2
gentoo-36b65c0cc3a13b57c1236c787bc290d2f229d43d.zip
app-admin/apachetop: version bump.
Bumping the version to latest 0.18.4. Closes: https://bugs.gentoo.org/654970 Package-Manager: Portage-2.3.33, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8270
Diffstat (limited to 'app-admin/apachetop/apachetop-0.18.4.ebuild')
-rw-r--r--app-admin/apachetop/apachetop-0.18.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/apachetop/apachetop-0.18.4.ebuild b/app-admin/apachetop/apachetop-0.18.4.ebuild
new file mode 100644
index 000000000000..2f5954eb82bf
--- /dev/null
+++ b/app-admin/apachetop/apachetop-0.18.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A realtime Apache log analyzer"
+HOMEPAGE="https://github.com/tessus/apachetop"
+SRC_URI="https://github.com/tessus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="fam pcre"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ fam? ( virtual/fam )
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-logfile="${EPREFIX}"/var/log/apache2/access_log \
+ --without-adns \
+ $(use_with fam) \
+ $(use_with pcre)
+}