summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-11-30 00:22:40 +0800
committerJason Zaman <perfinion@gentoo.org>2019-12-02 22:48:26 +0800
commit4985eefbed72c09a139534b69867bfb005983e57 (patch)
treefa809d0063ac3a5fe6eeea54cf69da022ed0fdd4 /app-admin
parentsys-process/audit: add python3_7 (diff)
downloadgentoo-4985eefbed72c09a139534b69867bfb005983e57.tar.gz
gentoo-4985eefbed72c09a139534b69867bfb005983e57.tar.bz2
gentoo-4985eefbed72c09a139534b69867bfb005983e57.zip
app-admin/setools: add python3_7
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/setools/setools-4.2.2.ebuild3
-rw-r--r--app-admin/setools/setools-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/app-admin/setools/setools-4.2.2.ebuild b/app-admin/setools/setools-4.2.2.ebuild
index 22da7166d078..20bb81b9fcd1 100644
--- a/app-admin/setools/setools-4.2.2.ebuild
+++ b/app-admin/setools/setools-4.2.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-PYTHON_COMPAT=( python3_5 python3_6 )
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
inherit distutils-r1
@@ -20,6 +20,7 @@ fi
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
IUSE="X test"
+RESTRICT="!test? ( test )"
S="${WORKDIR}/${PN}"
RDEPEND="${PYTHON_DEPS}
diff --git a/app-admin/setools/setools-9999.ebuild b/app-admin/setools/setools-9999.ebuild
index 8df9cb7cd407..96ff5057cd8e 100644
--- a/app-admin/setools/setools-9999.ebuild
+++ b/app-admin/setools/setools-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-PYTHON_COMPAT=( python3_5 python3_6 )
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
inherit distutils-r1
@@ -20,6 +20,7 @@ fi
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
IUSE="X test"
+RESTRICT="!test? ( test )"
RDEPEND="${PYTHON_DEPS}
>=dev-python/networkx-2.0[${PYTHON_USEDEP}]