summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-20 17:21:17 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-20 18:35:34 +0200
commita2b84ee1004c92153ab3d9feda7185d51eb2ebd8 (patch)
tree76920f66871b407977532fd60cd445827dd13c0b /app-arch
parentsys-fs/owfs: Disable php support (#651106 by Brian Evans) (diff)
downloadgentoo-a2b84ee1004c92153ab3d9feda7185d51eb2ebd8.tar.gz
gentoo-a2b84ee1004c92153ab3d9feda7185d51eb2ebd8.tar.bz2
gentoo-a2b84ee1004c92153ab3d9feda7185d51eb2ebd8.zip
app-arch/afio: Fix control file handling (#651294 by John R. Graham)
Closes: https://bugs.gentoo.org/651294 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/afio/afio-2.5.1-r2.ebuild34
-rw-r--r--app-arch/afio/files/afio-2.5.1-control-file-warning-fix.patch29
2 files changed, 63 insertions, 0 deletions
diff --git a/app-arch/afio/afio-2.5.1-r2.ebuild b/app-arch/afio/afio-2.5.1-r2.ebuild
new file mode 100644
index 000000000000..fced7417de80
--- /dev/null
+++ b/app-arch/afio/afio-2.5.1-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Afio creates cpio-format archives."
+HOMEPAGE="http://members.chello.nl/k.holtman/afio.html https://github.com/kholtman/afio"
+SRC_URI="http://members.chello.nl/k.holtman/${P}.tgz"
+
+LICENSE="Artistic LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.1-fix-build-system.patch
+ "${FILESDIR}"/${PN}-2.5.1-control-file-warning-fix.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ dodoc ANNOUNCE-* HISTORY README SCRIPTS
+
+ local i
+ for i in {1..4}; do
+ docinto "script${i}"
+ dodoc -r "script${i}"/.
+ done
+}
diff --git a/app-arch/afio/files/afio-2.5.1-control-file-warning-fix.patch b/app-arch/afio/files/afio-2.5.1-control-file-warning-fix.patch
new file mode 100644
index 000000000000..f1c93c8e914c
--- /dev/null
+++ b/app-arch/afio/files/afio-2.5.1-control-file-warning-fix.patch
@@ -0,0 +1,29 @@
+Only in b: 1
+diff -ubBr a/afio.c b/afio.c
+--- a/afio.c 2018-03-23 09:16:07.230401966 -0400
++++ b/afio.c 2018-03-23 09:20:05.614421756 -0400
+@@ -3724,7 +3724,8 @@
+
+ /* ASX check if file changed between the begining
+ and end of the backup */
+- if (*fsname)
++ /* if *fsname==0, it was a control file, so do not check then */
++ if (*fsname!=0)
+ {
+ struct stat st;
+ /* I must check fsname !
+@@ -3739,13 +3740,10 @@
+ if (st.st_mtime!=sb.sb_mtime)
+ {
+ warn (fsname, "File was modified during its backup");
++ if(index(ignorewarnings,(int)'d')) warnings--;
+ }
+ }
+ }
+- else
+- {
+- warn (name, "ASX no fsname for this name ??");
+- }
+
+ if(aflag && *fsname && ((sb.sb_mode & S_IFMT)==S_IFREG))
+ {