summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-05-05 02:04:56 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-15 18:26:08 +0200
commitbaed68221030b4fe96e31ba2dc74702eb43b27b2 (patch)
tree564c0084800737f6ef7440b4f1af75c2807045f4 /app-benchmarks/stress-ng/files
parentprofiles: package.use.mask include consumers of virtual/mysql[embedded] (diff)
downloadgentoo-baed68221030b4fe96e31ba2dc74702eb43b27b2.tar.gz
gentoo-baed68221030b4fe96e31ba2dc74702eb43b27b2.tar.bz2
gentoo-baed68221030b4fe96e31ba2dc74702eb43b27b2.zip
app-benchmarks/stress-ng: Bump to version 0.09.26
Closes: https://bugs.gentoo.org/650140 Closes: https://github.com/gentoo/gentoo/pull/8264 Package-Manager: Portage-2.3.35, Repoman-2.3.9
Diffstat (limited to 'app-benchmarks/stress-ng/files')
-rw-r--r--app-benchmarks/stress-ng/files/makefile.patch81
1 files changed, 81 insertions, 0 deletions
diff --git a/app-benchmarks/stress-ng/files/makefile.patch b/app-benchmarks/stress-ng/files/makefile.patch
new file mode 100644
index 000000000000..eecb12cad5b4
--- /dev/null
+++ b/app-benchmarks/stress-ng/files/makefile.patch
@@ -0,0 +1,81 @@
+--- a/Makefile 2018-04-27 17:02:16.000000000 +0200
++++ b/Makefile 2018-05-13 20:54:08.741008488 +0200
+@@ -21,7 +21,7 @@
+ # Codename "portable pressure producer"
+ #
+
+-CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2 -std=gnu99
++CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"'
+
+ #
+ # Pedantic flags
+@@ -314,12 +314,9 @@
+ .o: stress-ng.h Makefile
+
+ .c.o: stress-ng.h Makefile $(SRC)
+- @echo "CC $<"
+- @$(CC) $(CFLAGS) -c -o $@ $<
+
+ stress-ng: info $(OBJS)
+- @echo "LD $@"
+- @$(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -lc -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -lc -o $@
+ @sync
+
+ .PHONY: info
+@@ -339,8 +336,7 @@
+ sed '$$ s/.$$//' >> apparmor-data.c
+ @echo "};" >> apparmor-data.c
+ @echo "const size_t g_apparmor_data_len = sizeof(g_apparmor_data);" >> apparmor-data.c
+- @echo "CC $<"
+- @$(CC) -c apparmor-data.c -o apparmor-data.o
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c apparmor-data.c -o apparmor-data.o
+ @rm -rf apparmor-data.c
+
+ #
+@@ -353,20 +349,15 @@
+ stress-personality.c: personality.h
+
+ perf.o: perf.c perf-event.c
+- @$(CC) -E perf-event.c | grep "PERF_COUNT" | sed 's/,/ /' | awk {'print "#define _SNG_" $$1 " (1)"'} > perf-event.h
+- @echo CC $<
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -E perf-event.c | grep "PERF_COUNT" | sed 's/,/ /' | awk {'print "#define _SNG_" $$1 " (1)"'} > perf-event.h
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ stress-vecmath.o: stress-vecmath.c
+- @echo CC $<
+- @$(CC) $(CFLAGS) -fno-builtin -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -fno-builtin -c -o $@ $<
+ @touch stress-ng.c
+
+ $(OBJS): stress-ng.h Makefile
+
+-stress-ng.1.gz: stress-ng.1
+- gzip -c $< > $@
+-
+ .PHONY: dist
+ dist:
+ rm -rf stress-ng-$(VERSION)
+@@ -386,7 +377,7 @@
+
+ .PHONY: clean
+ clean:
+- @rm -f stress-ng $(OBJS) stress-ng.1.gz stress-ng.pdf
++ @rm -f stress-ng $(OBJS) stress-ng.pdf
+ @rm -f stress-ng-$(VERSION).tar.xz
+ @rm -f personality.h
+ @rm -f perf-event.h
+@@ -398,10 +389,10 @@
+ STRESS_NG=./stress-ng debian/tests/fast-test-all
+
+ .PHONY: install
+-install: stress-ng stress-ng.1.gz
++install: stress-ng
+ mkdir -p ${DESTDIR}${BINDIR}
+ cp stress-ng ${DESTDIR}${BINDIR}
+ mkdir -p ${DESTDIR}${MANDIR}
+- cp stress-ng.1.gz ${DESTDIR}${MANDIR}
++ cp stress-ng.1 ${DESTDIR}${MANDIR}
+ mkdir -p ${DESTDIR}${JOBDIR}
+ cp -rp example-jobs/*.job ${DESTDIR}${JOBDIR}