summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/burn-cd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/burn-cd')
-rw-r--r--app-cdr/burn-cd/Manifest2
-rw-r--r--app-cdr/burn-cd/burn-cd-1.7.4.ebuild21
-rw-r--r--app-cdr/burn-cd/burn-cd-1.8.0-r1.ebuild32
-rw-r--r--app-cdr/burn-cd/metadata.xml9
4 files changed, 64 insertions, 0 deletions
diff --git a/app-cdr/burn-cd/Manifest b/app-cdr/burn-cd/Manifest
new file mode 100644
index 000000000000..c28ca4cbf31c
--- /dev/null
+++ b/app-cdr/burn-cd/Manifest
@@ -0,0 +1,2 @@
+DIST burn-cd-1.7.4.gz 14618 SHA256 2b86395358adf96a5b0b60c8869f1d2e62e6c7d43c9d6eabd64899c9f2ef2f66 SHA512 21009659342b284654cec17ac597a5d8f7421a3c0112937db1b70563a42f00a781a7156eeb3877d9c23d6338cffa525cf2f25e4191d9444cca72c4821c9690d6 WHIRLPOOL af2bf7f9832676fe9f508828445d4e41586caee14ff90ce8d50a9e9ac16a0a71290002d5eb92140b2430729700021ee507e72b9a615832840144cc7908230be4
+DIST burn-cd-1.8.0.gz 14977 SHA256 89b01f1c736ffa494aa3d089516db479e0567c5f3784c96df5ce87a4880bbf75 SHA512 d052d6bd909af3f3c96cee727e222e179d913aa42c2d2afe8104c57b5263b06f318d6ec870ad2862779d757c4d522b7d82892eb0725255261a28243c919b82cf WHIRLPOOL 6a08964511a5a27803d6941971b923e8b73a90cfee7d137d529c313815b2ed911f0a2e4478b2272c465fd96421d83c9f5db1b6cbc81f6c9272c31aebfb287019
diff --git a/app-cdr/burn-cd/burn-cd-1.7.4.ebuild b/app-cdr/burn-cd/burn-cd-1.7.4.ebuild
new file mode 100644
index 000000000000..e2cc44ec546a
--- /dev/null
+++ b/app-cdr/burn-cd/burn-cd-1.7.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Smart console frontend for virtual/cdrtools and dvd+rw-tools"
+HOMEPAGE="http://burn-cd.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-lang/python
+ virtual/cdrtools
+ app-cdr/dvd+rw-tools"
+DEPEND=""
+
+src_install() {
+ newbin ${P} ${PN} || die "newbin failed."
+}
diff --git a/app-cdr/burn-cd/burn-cd-1.8.0-r1.ebuild b/app-cdr/burn-cd/burn-cd-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..15579094da7f
--- /dev/null
+++ b/app-cdr/burn-cd/burn-cd-1.8.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Smart console frontend for virtual/cdrtools and dvd+rw-tools"
+HOMEPAGE="http://burn-cd.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ virtual/cdrtools
+ app-cdr/dvd+rw-tools"
+DEPEND=""
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}
+
+src_install() {
+ python_fix_shebang ${P}
+ newbin ${P} ${PN}
+}
diff --git a/app-cdr/burn-cd/metadata.xml b/app-cdr/burn-cd/metadata.xml
new file mode 100644
index 000000000000..e44077c4cb8e
--- /dev/null
+++ b/app-cdr/burn-cd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-optical</herd>
+ <longdescription>CD and DVD command line recording and ripping tools.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">burn-cd</remote-id>
+ </upstream>
+</pkgmetadata>