summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-10-20 11:18:12 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-10-20 11:18:12 -0500
commit2fac0b2c4f4041cdd2bdfadeecbbfdefbf60a058 (patch)
tree78f164a858f39f0e2659501e71ab6f0e3745c8fd /app-containers
parentapp-containers/syft: add 0.59.0 (diff)
downloadgentoo-2fac0b2c4f4041cdd2bdfadeecbbfdefbf60a058.tar.gz
gentoo-2fac0b2c4f4041cdd2bdfadeecbbfdefbf60a058.tar.bz2
gentoo-2fac0b2c4f4041cdd2bdfadeecbbfdefbf60a058.zip
app-containers/grype: add 0.51.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/grype/Manifest2
-rw-r--r--app-containers/grype/grype-0.51.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/app-containers/grype/Manifest b/app-containers/grype/Manifest
index c184dcafe88d..7332f8e205c8 100644
--- a/app-containers/grype/Manifest
+++ b/app-containers/grype/Manifest
@@ -4,3 +4,5 @@ DIST grype-0.45.0-deps.tar.xz 644905072 BLAKE2B 5f1dd53106798b861ed90ed502406aa8
DIST grype-0.45.0.tar.gz 1074637 BLAKE2B 4cfa86a0ad695971241c40f19f982f54654642ff31f7220583af3b3aa0c1d6ca56f613e96b7343c4cb32b567efeb81c2145c19f009183b3d7f23ddeb1f01e02d SHA512 0a899c420d3d6ed9e669a0d02b0d79f0c63d50288b31c44cbbe61a883d46b93bf98be263cd7859d392ee40b82754c8cbe9b284dec593f79c5906988b01369209
DIST grype-0.48.0-deps.tar.xz 648540700 BLAKE2B 4332364215da90be1978b4d7038b6ef3ee72c33f5e98c432999ee8335047bf0516c45aeb8854f7e9d6a33055194c45246da32f3bab98aaabf9c4c8346c3a014b SHA512 7034b5662700a440a29f0cdbb870c65fd6d5fca47abb58762da88f0e70918d2436e603baf53dab0340074ff586f1bd71350254f65be153f3d1d03a36d0fba28b
DIST grype-0.48.0.tar.gz 1077714 BLAKE2B ec30c6421eb7ce9ef1d22a81db3149a076efcd32659471ff1f4ef00fe79176baf16ad6f1d682167c45349baff2bd49fda4207c84883ab5ac6e01b7e54bfb4af0 SHA512 9c7a27b10ce527ee0b131e60406ad2a8c6f28fbb138b475abd799a7b28f3709c987298bb6f8364f784a4fbe780d00ccd1061a0fb5066c63b5a1c42a5ea2b2d58
+DIST grype-0.51.0-deps.tar.xz 601816220 BLAKE2B 441982389af5e33cbe988571464cad0303b15971a5ed8b99c07b4d92404a6e636842e783b69c9f6f7de21c453edd9bfed5d78b60ebaa75abce55da638792205f SHA512 5e384ccd7ea6f777f4dbcdc8eff38402a965e87c68174e9ac4e33522b49b194e14a12104308df80ca6291dae934979750de5ccd8b38edc0fd6fb6be460705df0
+DIST grype-0.51.0.tar.gz 1124375 BLAKE2B 6d2fb92edd2bc174d0879426f56812be7ede7e8c83cae49a0dee9781b0a771592f352b9a4fb96f87e8031592295c255e041bf30d0e5be5c24887c8436d505cf8 SHA512 4d1868a74523279734239836421c6a17595baa3179c80d18dba04cc5188e29eb5d97bc3102c931e9b1995a9afbc1da03d95d52bb8d74f5465c7415a1b16f947c
diff --git a/app-containers/grype/grype-0.51.0.ebuild b/app-containers/grype/grype-0.51.0.ebuild
new file mode 100644
index 000000000000..95d05f2b66cf
--- /dev/null
+++ b/app-containers/grype/grype-0.51.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=4cda526992d5003dcbab68c9a7479a653dfde008
+SYFT_VERSION=0.59.0
+
+DESCRIPTION="A vulnerability scanner for container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/grype/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require a running docker
+RESTRICT="test"
+
+src_compile() {
+ ego build -o bin/grype -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/grype/internal/version.version=${PV}
+ -X github.com/anchore/grype/internal/version.syftVersion=${SYFT_VERSION}
+ -X github.com/anchore/grype/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/grype/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/grype/internal/version.gitDescription=v${PV}"
+}
+
+src_install() {
+ dobin bin/grype
+}