summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-03-27 01:38:19 +0530
committerZac Medico <zmedico@gentoo.org>2024-03-26 19:37:22 -0700
commit4b93b64a41c31348e4bab02d3032a96ece3bfe16 (patch)
tree9c8c3a6d2754b9de8ca74ca07bbaf8c1a1ad6c8e /app-containers
parentapp-containers/buildah: fix calling as directly (diff)
downloadgentoo-4b93b64a41c31348e4bab02d3032a96ece3bfe16.tar.gz
gentoo-4b93b64a41c31348e4bab02d3032a96ece3bfe16.tar.bz2
gentoo-4b93b64a41c31348e4bab02d3032a96ece3bfe16.zip
app-containers/buildah: add go-md2man as BDEPEND and ...
remove unnecessary build steps which were running tests resulting in failed build on arm64 (and potentially other archs). Closes: https://bugs.gentoo.org/888571 Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Closes: https://github.com/gentoo/gentoo/pull/35931 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/buildah/buildah-1.33.7.ebuild5
-rw-r--r--app-containers/buildah/buildah-1.34.3.ebuild5
-rw-r--r--app-containers/buildah/buildah-1.35.1.ebuild5
-rw-r--r--app-containers/buildah/buildah-9999.ebuild5
4 files changed, 20 insertions, 0 deletions
diff --git a/app-containers/buildah/buildah-1.33.7.ebuild b/app-containers/buildah/buildah-1.33.7.ebuild
index f100d2a5a83a..789e12962aa5 100644
--- a/app-containers/buildah/buildah-1.33.7.ebuild
+++ b/app-containers/buildah/buildah-1.33.7.ebuild
@@ -42,6 +42,7 @@ RDEPEND="
sys-apps/shadow:=
"
DEPEND="${RDEPEND}"
+BDEPEND="dev-go/go-md2man"
pkg_pretend() {
local CONFIG_CHECK=""
@@ -98,6 +99,9 @@ src_prepare() {
@@ -54 +54 @@
-all: bin/buildah bin/imgtype bin/copy bin/tutorial docs
+all: bin/buildah docs
+ @@ -123 +123 @@
+ -docs: install.tools ## build the docs on the host
+ +docs: ## build the docs on the host
EOF
eapply "${T}/disable_tests.patch" || die
}
@@ -110,6 +114,7 @@ src_compile() {
[[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT=""
tc-export AS LD
+ export GOMD2MAN="$(command -v go-md2man)"
default
}
diff --git a/app-containers/buildah/buildah-1.34.3.ebuild b/app-containers/buildah/buildah-1.34.3.ebuild
index f100d2a5a83a..789e12962aa5 100644
--- a/app-containers/buildah/buildah-1.34.3.ebuild
+++ b/app-containers/buildah/buildah-1.34.3.ebuild
@@ -42,6 +42,7 @@ RDEPEND="
sys-apps/shadow:=
"
DEPEND="${RDEPEND}"
+BDEPEND="dev-go/go-md2man"
pkg_pretend() {
local CONFIG_CHECK=""
@@ -98,6 +99,9 @@ src_prepare() {
@@ -54 +54 @@
-all: bin/buildah bin/imgtype bin/copy bin/tutorial docs
+all: bin/buildah docs
+ @@ -123 +123 @@
+ -docs: install.tools ## build the docs on the host
+ +docs: ## build the docs on the host
EOF
eapply "${T}/disable_tests.patch" || die
}
@@ -110,6 +114,7 @@ src_compile() {
[[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT=""
tc-export AS LD
+ export GOMD2MAN="$(command -v go-md2man)"
default
}
diff --git a/app-containers/buildah/buildah-1.35.1.ebuild b/app-containers/buildah/buildah-1.35.1.ebuild
index f5596936ec24..ecf84e28950c 100644
--- a/app-containers/buildah/buildah-1.35.1.ebuild
+++ b/app-containers/buildah/buildah-1.35.1.ebuild
@@ -42,6 +42,7 @@ RDEPEND="
sys-apps/shadow:=
"
DEPEND="${RDEPEND}"
+BDEPEND="dev-go/go-md2man"
pkg_pretend() {
local CONFIG_CHECK=""
@@ -98,6 +99,9 @@ src_prepare() {
@@ -54 +54 @@
-all: bin/buildah bin/imgtype bin/copy bin/tutorial docs
+all: bin/buildah docs
+ @@ -123 +123 @@
+ -docs: install.tools ## build the docs on the host
+ +docs: ## build the docs on the host
EOF
eapply "${T}/disable_tests.patch" || die
}
@@ -110,6 +114,7 @@ src_compile() {
[[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT=""
tc-export AS LD
+ export GOMD2MAN="$(command -v go-md2man)"
default
}
diff --git a/app-containers/buildah/buildah-9999.ebuild b/app-containers/buildah/buildah-9999.ebuild
index f5596936ec24..ecf84e28950c 100644
--- a/app-containers/buildah/buildah-9999.ebuild
+++ b/app-containers/buildah/buildah-9999.ebuild
@@ -42,6 +42,7 @@ RDEPEND="
sys-apps/shadow:=
"
DEPEND="${RDEPEND}"
+BDEPEND="dev-go/go-md2man"
pkg_pretend() {
local CONFIG_CHECK=""
@@ -98,6 +99,9 @@ src_prepare() {
@@ -54 +54 @@
-all: bin/buildah bin/imgtype bin/copy bin/tutorial docs
+all: bin/buildah docs
+ @@ -123 +123 @@
+ -docs: install.tools ## build the docs on the host
+ +docs: ## build the docs on the host
EOF
eapply "${T}/disable_tests.patch" || die
}
@@ -110,6 +114,7 @@ src_compile() {
[[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT=""
tc-export AS LD
+ export GOMD2MAN="$(command -v go-md2man)"
default
}