summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2018-05-31 23:09:22 +0100
committerMike Auty <ikelos@gentoo.org>2018-05-31 23:09:22 +0100
commitb2168c789622195e6e0b6e001b6d942e2149edee (patch)
treead1555ce68f12b1d486948d805dc9035ac72161b /app-crypt/ophcrack/ophcrack-3.8.0.ebuild
parentsci-visualization/gnuplot: ppc/ppc64 stable wrt bug #655222 (diff)
downloadgentoo-b2168c789622195e6e0b6e001b6d942e2149edee.tar.gz
gentoo-b2168c789622195e6e0b6e001b6d942e2149edee.tar.bz2
gentoo-b2168c789622195e6e0b6e001b6d942e2149edee.zip
app-crypt/ophcrack: Bump to 3.8.0 (and drop ppc due to qtcharts)
dev-qt/qtcharts-5 isn't keyworded for ppc, so we've dropped ppc support until then. Fixes issue 656932. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-crypt/ophcrack/ophcrack-3.8.0.ebuild')
-rw-r--r--app-crypt/ophcrack/ophcrack-3.8.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/ophcrack/ophcrack-3.8.0.ebuild b/app-crypt/ophcrack/ophcrack-3.8.0.ebuild
new file mode 100644
index 000000000000..9165b752e558
--- /dev/null
+++ b/app-crypt/ophcrack/ophcrack-3.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit eutils
+
+DESCRIPTION="A time-memory-trade-off-cracker"
+HOMEPAGE="http://ophcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug libressl qt5 +tables"
+
+CDEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-libs/netwib
+ qt5? ( dev-qt/qtcharts:5
+ dev-qt/qtgui:5 )"
+DEPEND="app-arch/unzip
+ virtual/pkgconfig
+ ${CDEPEND}"
+RDEPEND="tables? ( app-crypt/ophcrack-tables )
+ ${CDEPEND}"
+
+src_configure() {
+
+ local myconf
+
+ myconf="$(use_enable debug)"
+ myconf="${myconf} $(use_enable qt5 gui)"
+
+ econf ${myconf} || die "Failed to compile"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Installation failed."
+
+ cd "${S}"
+ newicon src/gui/pixmaps/os.xpm ophcrack.xpm
+ make_desktop_entry "${PN}" OphCrack ophcrack
+}