summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-10 16:43:02 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-10 16:43:50 -0700
commitc144ca1941706b0b897a09253fa9c68fa0f3882e (patch)
treeb920b451dd1b749cae7021407f391d61bae860ca /app-crypt
parentapp-crypt/minisign: new package (diff)
downloadgentoo-c144ca1941706b0b897a09253fa9c68fa0f3882e.tar.gz
gentoo-c144ca1941706b0b897a09253fa9c68fa0f3882e.tar.bz2
gentoo-c144ca1941706b0b897a09253fa9c68fa0f3882e.zip
app-crypt/minisign: add live ebuild
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/minisign/minisign-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-crypt/minisign/minisign-9999.ebuild b/app-crypt/minisign/minisign-9999.ebuild
new file mode 100644
index 000000000000..da90d6d5d3f4
--- /dev/null
+++ b/app-crypt/minisign/minisign-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Dead simple tool to sign files and verify signatures"
+HOMEPAGE="https://github.com/jedisct1/minisign"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jedisct1/${PN}.git"
+else
+ SRC_URI="https://github.com/jedisct1/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+
+IUSE=""
+
+DEPEND=">=dev-libs/libsodium-1.0.16:=[-minimal]"
+RDEPEND="${DEPEND}"