summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-02-20 08:46:16 +0100
committerUlrich Müller <ulm@gentoo.org>2018-02-20 08:46:58 +0100
commite5a9c9adc17b23caef553261234630cbad4fccff (patch)
tree6c1c5204965c45532d33078bac8282111e3f2267 /app-editors
parentapp-editors/emacs: Disable the sandbox only when dumping. (diff)
downloadgentoo-e5a9c9adc17b23caef553261234630cbad4fccff.tar.gz
gentoo-e5a9c9adc17b23caef553261234630cbad4fccff.tar.bz2
gentoo-e5a9c9adc17b23caef553261234630cbad4fccff.zip
app-editors/emacs-vcs: Disable the sandbox only when dumping.
Note that unsetting LD_PRELOAD will have an effect only for >=sys-apps/sandbox-2.13. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild12
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-26.0.91.ebuild12
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-26.0.9999-r1.ebuild12
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild12
4 files changed, 40 insertions, 8 deletions
diff --git a/app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild b/app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild
index 2153ada2274b..b332683366c3 100644
--- a/app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild
@@ -273,8 +273,16 @@ src_configure() {
}
src_compile() {
- export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
- emake
+ # Disable sandbox when dumping. For the unbelievers, see bug #131505
+ cat >src/temacs-wrapper <<-'EOF' || die
+ #!/bin/bash
+ export SANDBOX_ON=0
+ unset LD_PRELOAD
+ exec ./temacs "$@"
+ EOF
+ chmod +x src/temacs-wrapper || die
+
+ emake RUN_TEMACS="./temacs-wrapper"
}
src_install () {
diff --git a/app-editors/emacs-vcs/emacs-vcs-26.0.91.ebuild b/app-editors/emacs-vcs/emacs-vcs-26.0.91.ebuild
index 2153ada2274b..b332683366c3 100644
--- a/app-editors/emacs-vcs/emacs-vcs-26.0.91.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-26.0.91.ebuild
@@ -273,8 +273,16 @@ src_configure() {
}
src_compile() {
- export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
- emake
+ # Disable sandbox when dumping. For the unbelievers, see bug #131505
+ cat >src/temacs-wrapper <<-'EOF' || die
+ #!/bin/bash
+ export SANDBOX_ON=0
+ unset LD_PRELOAD
+ exec ./temacs "$@"
+ EOF
+ chmod +x src/temacs-wrapper || die
+
+ emake RUN_TEMACS="./temacs-wrapper"
}
src_install () {
diff --git a/app-editors/emacs-vcs/emacs-vcs-26.0.9999-r1.ebuild b/app-editors/emacs-vcs/emacs-vcs-26.0.9999-r1.ebuild
index 2153ada2274b..b332683366c3 100644
--- a/app-editors/emacs-vcs/emacs-vcs-26.0.9999-r1.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-26.0.9999-r1.ebuild
@@ -273,8 +273,16 @@ src_configure() {
}
src_compile() {
- export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
- emake
+ # Disable sandbox when dumping. For the unbelievers, see bug #131505
+ cat >src/temacs-wrapper <<-'EOF' || die
+ #!/bin/bash
+ export SANDBOX_ON=0
+ unset LD_PRELOAD
+ exec ./temacs "$@"
+ EOF
+ chmod +x src/temacs-wrapper || die
+
+ emake RUN_TEMACS="./temacs-wrapper"
}
src_install () {
diff --git a/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
index e2c11b5e4c51..9cf901fe95f7 100644
--- a/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
@@ -273,8 +273,16 @@ src_configure() {
}
src_compile() {
- export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
- emake
+ # Disable sandbox when dumping. For the unbelievers, see bug #131505
+ cat >src/temacs-wrapper <<-'EOF' || die
+ #!/bin/bash
+ export SANDBOX_ON=0
+ unset LD_PRELOAD
+ exec ./temacs "$@"
+ EOF
+ chmod +x src/temacs-wrapper || die
+
+ emake RUN_TEMACS="./temacs-wrapper"
}
src_install () {