summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2017-12-05 10:21:10 +0800
committerYixun Lan <dlan@gentoo.org>2017-12-05 10:24:31 +0800
commit111558ba21f63d5782a5509c0ed0d0a29bdbffd4 (patch)
treec8f00ad27d683aec8f5e5e23ad945bd1061cb1c9 /app-emulation
parentapp-emulation/xen: obsolete epatch if EAPI=6 (diff)
downloadgentoo-111558ba21f63d5782a5509c0ed0d0a29bdbffd4.tar.gz
gentoo-111558ba21f63d5782a5509c0ed0d0a29bdbffd4.tar.bz2
gentoo-111558ba21f63d5782a5509c0ed0d0a29bdbffd4.zip
app-emulation/xen-tools: obsolete epatch in EAPI=6
replace epatch with eapply Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-tools/xen-tools-4.8.2-r3.ebuild20
-rw-r--r--app-emulation/xen-tools/xen-tools-4.9.1.ebuild20
2 files changed, 12 insertions, 28 deletions
diff --git a/app-emulation/xen-tools/xen-tools-4.8.2-r3.ebuild b/app-emulation/xen-tools/xen-tools-4.8.2-r3.ebuild
index c8bbd81561c6..211478319ae4 100644
--- a/app-emulation/xen-tools/xen-tools-4.8.2-r3.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.8.2-r3.ebuild
@@ -179,10 +179,7 @@ src_prepare() {
# Upstream's patchset
if [[ -n ${UPSTREAM_VER} ]]; then
einfo "Try to apply Xen Upstream patch set"
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- EPATCH_OPTS="-p1" \
- epatch "${WORKDIR}"/patches-upstream
+ eapply "${WORKDIR}"/patches-upstream
fi
# Security patchset
@@ -197,20 +194,20 @@ src_prepare() {
source "${WORKDIR}"/patches-security/${PV}.conf || die
for i in ${XEN_SECURITY_MAIN}; do
- epatch "${WORKDIR}"/patches-security/xen/$i
+ eapply "${WORKDIR}"/patches-security/xen/$i
done
# apply qemu-xen/upstream patches
pushd "${S}"/tools/qemu-xen/ > /dev/null
for i in ${XEN_SECURITY_QEMUU}; do
- epatch "${WORKDIR}"/patches-security/qemuu/$i
+ eapply "${WORKDIR}"/patches-security/qemuu/$i
done
popd > /dev/null
# apply qemu-traditional patches
pushd "${S}"/tools/qemu-xen-traditional/ > /dev/null
for i in ${XEN_SECURITY_QEMUT}; do
- epatch "${WORKDIR}"/patches-security/qemut/$i
+ eapply "${WORKDIR}"/patches-security/qemut/$i
done
popd > /dev/null
fi
@@ -227,9 +224,7 @@ src_prepare() {
source "${FILESDIR}"/gentoo-patches.conf || die
_gpv=_gpv_${PN/-/_}_${PV//./}_${GENTOO_GPV}
for i in ${!_gpv}; do
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- epatch "${WORKDIR}"/patches-gentoo/$i
+ eapply "${WORKDIR}"/patches-gentoo/$i
done
fi
@@ -238,10 +233,7 @@ src_prepare() {
if [[ -n ${OVMF_VER} ]];then
einfo "Try to apply Ovmf patch set"
pushd "${WORKDIR}"/ovmf-*/ > /dev/null
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- EPATCH_OPTS="-p1" \
- epatch "${WORKDIR}"/patches-ovmf
+ eapply "${WORKDIR}"/patches-ovmf
popd > /dev/null
fi
mv ../ovmf-${OVMF_PV} tools/firmware/ovmf-dir-remote || die
diff --git a/app-emulation/xen-tools/xen-tools-4.9.1.ebuild b/app-emulation/xen-tools/xen-tools-4.9.1.ebuild
index e15cda8916a3..665372875faf 100644
--- a/app-emulation/xen-tools/xen-tools-4.9.1.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.9.1.ebuild
@@ -180,10 +180,7 @@ src_prepare() {
# Upstream's patchset
if [[ -n ${UPSTREAM_VER} ]]; then
einfo "Try to apply Xen Upstream patch set"
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- EPATCH_OPTS="-p1" \
- epatch "${WORKDIR}"/patches-upstream
+ eapply "${WORKDIR}"/patches-upstream
fi
# Security patchset
@@ -198,20 +195,20 @@ src_prepare() {
source "${WORKDIR}"/patches-security/${PV}.conf || die
for i in ${XEN_SECURITY_MAIN}; do
- epatch "${WORKDIR}"/patches-security/xen/$i
+ eapply "${WORKDIR}"/patches-security/xen/$i
done
# apply qemu-xen/upstream patches
pushd "${S}"/tools/qemu-xen/ > /dev/null
for i in ${XEN_SECURITY_QEMUU}; do
- epatch "${WORKDIR}"/patches-security/qemuu/$i
+ eapply "${WORKDIR}"/patches-security/qemuu/$i
done
popd > /dev/null
# apply qemu-traditional patches
pushd "${S}"/tools/qemu-xen-traditional/ > /dev/null
for i in ${XEN_SECURITY_QEMUT}; do
- epatch "${WORKDIR}"/patches-security/qemut/$i
+ eapply "${WORKDIR}"/patches-security/qemut/$i
done
popd > /dev/null
fi
@@ -228,9 +225,7 @@ src_prepare() {
source "${FILESDIR}"/gentoo-patches.conf || die
_gpv=_gpv_${PN/-/_}_${PV//./}_${GENTOO_GPV}
for i in ${!_gpv}; do
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- epatch "${WORKDIR}"/patches-gentoo/$i
+ eapply "${WORKDIR}"/patches-gentoo/$i
done
fi
@@ -239,10 +234,7 @@ src_prepare() {
if [[ -n ${OVMF_VER} ]];then
einfo "Try to apply Ovmf patch set"
pushd "${WORKDIR}"/ovmf-*/ > /dev/null
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- EPATCH_OPTS="-p1" \
- epatch "${WORKDIR}"/patches-ovmf
+ eapply "${WORKDIR}"/patches-ovmf
popd > /dev/null
fi
mv ../ovmf-${OVMF_PV} tools/firmware/ovmf-dir-remote || die