summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-11-03 15:26:48 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-11-03 15:26:48 +0100
commit21017a15627bf177fe34f4e9603bb1789cf0b584 (patch)
tree3ceeddb6a54d4375c215219339a371d4e6fd68e4 /app-emulation
parentapp-emulation/containerd: Remove old (diff)
downloadgentoo-21017a15627bf177fe34f4e9603bb1789cf0b584.tar.gz
gentoo-21017a15627bf177fe34f4e9603bb1789cf0b584.tar.bz2
gentoo-21017a15627bf177fe34f4e9603bb1789cf0b584.zip
app-emulation/containerd: Sync some changes to live ebuild
Package-Manager: Portage-2.3.12, Repoman-2.3.4
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/containerd/containerd-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/app-emulation/containerd/containerd-9999.ebuild b/app-emulation/containerd/containerd-9999.ebuild
index 42467124d22e..345b3fa9b966 100644
--- a/app-emulation/containerd/containerd-9999.ebuild
+++ b/app-emulation/containerd/containerd-9999.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-EGO_PN="github.com/docker/${PN}"
+EGO_PN="github.com/containerd/${PN}"
inherit toolchain-funcs
if [[ ${PV} == *9999 ]]; then
inherit golang-vcs
else
- MY_PV="${PV/_/-}"
+ MY_PV="${PV/_beta/-beta.}"
EGIT_COMMIT="v${MY_PV}"
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64"
+ KEYWORDS="~amd64 ~arm ~ppc64"
inherit golang-vcs-snapshot
fi
@@ -24,17 +24,17 @@ SLOT="0"
IUSE="hardened +seccomp"
DEPEND=""
-RDEPEND=">=app-emulation/runc-1.0.0_rc2
+RDEPEND=">=app-emulation/runc-1.0.0_rc4
seccomp? ( sys-libs/libseccomp )"
S=${WORKDIR}/${P}/src/${EGO_PN}
src_compile() {
- local options=( $(usex seccomp "seccomp") )
+ local options=( $(usex seccomp "seccomp" "") )
export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
}
src_install() {
- dobin bin/containerd* bin/ctr
+ dobin bin/containerd{-shim,-stress,} bin/ctr
}