summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-03 21:41:49 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-03 21:46:00 +0100
commit7e40b7e42500b6d96ece1ed217234f67e101432b (patch)
treebdf03e2056558274d950b2e14f33aa10b92b51be /app-emulation
parentdev-python/ansicolor: Remove py2 (diff)
downloadgentoo-7e40b7e42500b6d96ece1ed217234f67e101432b.tar.gz
gentoo-7e40b7e42500b6d96ece1ed217234f67e101432b.tar.bz2
gentoo-7e40b7e42500b6d96ece1ed217234f67e101432b.zip
app-emulation/docker-compose: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-compose/docker-compose-1.24.0.ebuild10
-rw-r--r--app-emulation/docker-compose/docker-compose-1.24.1.ebuild10
-rw-r--r--app-emulation/docker-compose/docker-compose-1.25.0-r1.ebuild12
-rw-r--r--app-emulation/docker-compose/docker-compose-1.25.1.ebuild12
-rw-r--r--app-emulation/docker-compose/docker-compose-1.25.2.ebuild10
-rw-r--r--app-emulation/docker-compose/docker-compose-1.25.3.ebuild10
-rw-r--r--app-emulation/docker-compose/docker-compose-1.25.4.ebuild10
7 files changed, 18 insertions, 56 deletions
diff --git a/app-emulation/docker-compose/docker-compose-1.24.0.ebuild b/app-emulation/docker-compose/docker-compose-1.24.0.ebuild
index 231ec1bd9f17..3e0bfb04269c 100644
--- a/app-emulation/docker-compose/docker-compose-1.24.0.ebuild
+++ b/app-emulation/docker-compose/docker-compose-1.24.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit bash-completion-r1 distutils-r1
@@ -29,15 +29,11 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/requests-2.18.1[${PYTHON_USEDEP}]
>=dev-python/six-1.3.0[${PYTHON_USEDEP}]
>=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )"
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
- <dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
+ <dev-python/pyyaml-5.1[${PYTHON_USEDEP}] )"
S="${WORKDIR}/compose-${PV}"
diff --git a/app-emulation/docker-compose/docker-compose-1.24.1.ebuild b/app-emulation/docker-compose/docker-compose-1.24.1.ebuild
index 12ac42d6a193..b310d81c22b2 100644
--- a/app-emulation/docker-compose/docker-compose-1.24.1.ebuild
+++ b/app-emulation/docker-compose/docker-compose-1.24.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit bash-completion-r1 distutils-r1
@@ -29,15 +29,11 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/requests-2.18.1[${PYTHON_USEDEP}]
>=dev-python/six-1.3.0[${PYTHON_USEDEP}]
>=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )"
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
- <dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
+ <dev-python/pyyaml-5.1[${PYTHON_USEDEP}] )"
S="${WORKDIR}/compose-${PV}"
diff --git a/app-emulation/docker-compose/docker-compose-1.25.0-r1.ebuild b/app-emulation/docker-compose/docker-compose-1.25.0-r1.ebuild
index a6f8868eab7b..ae28e4a89c37 100644
--- a/app-emulation/docker-compose/docker-compose-1.25.0-r1.ebuild
+++ b/app-emulation/docker-compose/docker-compose-1.25.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit bash-completion-r1 distutils-r1
@@ -29,17 +29,11 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
>=dev-python/six-1.3.0[${PYTHON_USEDEP}]
>=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/backports-shutil_get_terminal_size-1.0.0[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/subprocess32-3.5.4[${PYTHON_USEDEP}]' 'python2_7' )"
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
- <dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
+ <dev-python/pyyaml-5.1[${PYTHON_USEDEP}] )"
S="${WORKDIR}/compose-${PV}"
diff --git a/app-emulation/docker-compose/docker-compose-1.25.1.ebuild b/app-emulation/docker-compose/docker-compose-1.25.1.ebuild
index 2c7c3fe978b1..014701ba9c8b 100644
--- a/app-emulation/docker-compose/docker-compose-1.25.1.ebuild
+++ b/app-emulation/docker-compose/docker-compose-1.25.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit bash-completion-r1 distutils-r1
@@ -29,17 +29,11 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
>=dev-python/six-1.3.0[${PYTHON_USEDEP}]
>=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/backports-shutil_get_terminal_size-1.0.0[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/subprocess32-3.5.4[${PYTHON_USEDEP}]' 'python2_7' )"
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
- <dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
+ <dev-python/pyyaml-5.1[${PYTHON_USEDEP}] )"
S="${WORKDIR}/compose-${PV}"
diff --git a/app-emulation/docker-compose/docker-compose-1.25.2.ebuild b/app-emulation/docker-compose/docker-compose-1.25.2.ebuild
index 7bdd266df6a4..08fd06065eef 100644
--- a/app-emulation/docker-compose/docker-compose-1.25.2.ebuild
+++ b/app-emulation/docker-compose/docker-compose-1.25.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit bash-completion-r1 distutils-r1
@@ -29,18 +29,12 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
>=dev-python/six-1.3.0[${PYTHON_USEDEP}]
>=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/backports-shutil_get_terminal_size-1.0.0[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/subprocess32-3.5.4[${PYTHON_USEDEP}]' 'python2_7' )"
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (
<dev-python/pytest-4[${PYTHON_USEDEP}]
dev-python/ddt[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
)"
S="${WORKDIR}/compose-${PV}"
diff --git a/app-emulation/docker-compose/docker-compose-1.25.3.ebuild b/app-emulation/docker-compose/docker-compose-1.25.3.ebuild
index fa7ef8bfb516..90f18a6ef867 100644
--- a/app-emulation/docker-compose/docker-compose-1.25.3.ebuild
+++ b/app-emulation/docker-compose/docker-compose-1.25.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit bash-completion-r1 distutils-r1
@@ -29,18 +29,12 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
>=dev-python/six-1.3.0[${PYTHON_USEDEP}]
>=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/backports-shutil_get_terminal_size-1.0.0[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/subprocess32-3.5.4[${PYTHON_USEDEP}]' 'python2_7' )"
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (
<dev-python/pytest-4[${PYTHON_USEDEP}]
dev-python/ddt[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
)"
S="${WORKDIR}/compose-${PV}"
diff --git a/app-emulation/docker-compose/docker-compose-1.25.4.ebuild b/app-emulation/docker-compose/docker-compose-1.25.4.ebuild
index c7b13e93e7af..7fd5d941ab54 100644
--- a/app-emulation/docker-compose/docker-compose-1.25.4.ebuild
+++ b/app-emulation/docker-compose/docker-compose-1.25.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit bash-completion-r1 distutils-r1
@@ -30,18 +30,12 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
>=dev-python/six-1.3.0[${PYTHON_USEDEP}]
>=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/backports-shutil_get_terminal_size-1.0.0[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/subprocess32-3.5.4[${PYTHON_USEDEP}]' 'python2_7' )"
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (
<dev-python/pytest-4[${PYTHON_USEDEP}]
dev-python/ddt[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
)"
S="${WORKDIR}/compose-${PV}"